Interupted at 0%

Running Docker containers on Ubuntu 22.4 but keep getting “interrupted at 0%” Tried the fix in link Redis Container doesn't start but still have same issue.


you need to check the logs and the errors tab at the report details page for some hints about the issue.

Thanks, error tab says

Could not connect to Scanner
Interrupting scan because GVM is exiting.

Log says
osp_scanner_feed_version: failed to connect to /run/ospd/ospd-openvas.sock

root@xg-dmz:/home/lmqadmin# docker logs greenbone-community-edition_ospd-openvas_1
OSPD[8] 2023-12-14 12:07:34,616: INFO: (ospd.main) Starting OSPd OpenVAS version 22.6.2.
OSPD[8] 2023-12-14 12:07:34,621: INFO: (ospd_openvas.messaging.mqtt) Successfully connected to MQTT broker
OSPD[8] 2023-12-14 12:07:44,660: INFO: (ospd_openvas.daemon) Loading VTs. Scans will be [requested|queued] until VTs are loaded. This may take a few minutes, please wait…
OSPD[8] 2023-12-14 12:08:20,903: INFO: (ospd_openvas.daemon) Finished loading VTs. The VT cache has been updated from version 0 to 202312130556.
OSPD[8] 2023-12-14 12:09:26,998: INFO: (ospd.command.command) Scan 72ad4d46-adc0-4bf2-a40d-2138126b7691 added to the queue in position 2.
OSPD[8] 2023-12-14 12:09:36,953: INFO: (ospd.ospd) Currently 1 queued scans.
OSPD[8] 2023-12-14 12:09:37,083: INFO: (ospd.ospd) Starting scan 72ad4d46-adc0-4bf2-a40d-2138126b7691.
OSPD[8] 2023-12-14 12:09:59,897: ERROR: (ospd_openvas.daemon) Task 72ad4d46-adc0-4bf2-a40d-2138126b7691 was unexpectedly stopped or killed.

Could be the same issue as Couldn't initialize the plugin scheduler Please try running

docker compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition pull vulnerability-tests
docker compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition up -d vulnerability-tests

[+] Pulling 4/4
:heavy_check_mark: vulnerability-tests 3 layers [⣿⣿⣿] 0B/0B Pulled 37.7s
:heavy_check_mark: 6672f60b6ba8 Already exists 0.0s
:heavy_check_mark: 395d6dd5877d Pull complete 1.1s
:heavy_check_mark: e29e8c7281cb Pull complete
[+] Running 2/2
:heavy_check_mark: Container greenbone-community-edition_vulnerability-tests_1 Recreated 0.1s
:heavy_check_mark: Container greenbone-community-edition-vulnerability-tests-1 Started

somehow seems worse now, before it would go “Queued” then “running” then “interupted”… now it just goes from “Queued” to "interupted.

I suppose the new content wasn’t loaded yet. You need to wait some minutes.

How long? just tried again and same

In that case please check the logs for possible errors and take a look at the errors tab of the report details page.