If experiencing "interrupted 0%" - read here for possible cause!

Hi all!
If you experience the error message “interrupted 0%…” and all tasks failing when trying to use any of the “Alive test” besides “consider alive” like I was getting and stumbled upon for a few hours, I’d like to inform you that in my case the IPv6 was the culprit, as I’ve disabled IPv6 on that machine. I’ve also seen in the logs that the task was started and passed to the mqtt broker and immediately after it stopped without any apparent reason.
I found the culprit via this post ARPV6/ICMPV6 socket: Address family not supported by protocol.
I’m using Ubuntu 22.04 so the steps would be as follows:

  • edit the /etc/default/grub and delete the ipv6 disable part - #GRUB_CMDLINE_LINUX=“ipv6.disable=1” and then run sudo update-grub
  • disable via these sysctl commands:
sudo sysctl -w net.ipv6.conf.all.disable_ipv6=0
sudo sysctl -w net.ipv6.conf.default.disable_ipv6=0
sudo sysctl -w net.ipv6.conf.lo.disable_ipv6=0

After changing the above, a reboot would be required in order for the new settings to apply.
Hope this helps anybody.

1 Like