I need help I cant see the reports be sent out because of maximum length

Note: This report exceeds the maximum length of 1048576 characters and thus was truncated. Can anyone help me with this and making the maximum length longer so I can get reports?

Please have a look via the search engine for this “This report exceeds the maximum length” message to find existing topics with possible hints how to configure the limit like e.g.:

I did that and that’s back in 2019 the system changed from 2019 to 2023 so a lot of stuff is different

Ah, yes. But the only difference is that the daemon is now called gvmd instead of openvasmd but from Greenbone side nothing else changed on this matter.

The only difference might be that the settings needs to be included in the systemd file for the manager daemon, but this depends on the used environment and support might be required from some one familiar with it / from the community of the Linux distribution of your choice.

I’m using kali linux for this and I cant find the gvmd.conf file anywhere I tried looking in /etc/gvm folder and I cant find anything can you help me please?

  • I can’t see any reference to a gvmd.conf file anywhere in the linked topic so not sure where this info is originating from :-/
  • If systemd is used the file you are looking for is very likely gvmd.service and needs to be adjusted accordingly to pass something like e.g.:
    --max-email-attachment-size=4000000 --max-email-include-size=4000000 --max-email-message-size=4000000`
    
    to the gvmd binary in the ExecStart line
  • Unfortunately i’m not able to give more specific support as i’m not familiar with your setup / used installation method
  • Note that this info is also (but not that specific) in the topic linked above in various later comments
  • As updating such systemd specific files are not specific to the Greenbone software stack you might need to get more support from the community of the chosen Linux distribution

/lib/systemd/system/gvmd.service:19: Unknown key name ‘max-email-attachment-size’ in section ‘Service’, ignoring. this is what I’m getting

Can you still help me with this I changed the settings and the server crashed and then I’m still getting the emails are being truncated

Unfortunately i’m not familiar with your used environment as well as systemd service files and can’t give further support in addition to what have been already given previously.

Let’s see if some one else from the community is able to give more support. Otherwise it is suggested to ask for more support and / or documentation from the Kali community like mentioned previously.

I looked at the kali linux forum there is one person with the same problem but no one has responded. I don’t know where else to go. I’ve looked in the documentation but there’s nothing on the problem I am having

So I found the fix in the /lib/systemd/system folder the service gvmd.service you have to add this ExecStart=/usr/sbin/gvmd --osp-vt-update=/run/ospd/ospd.sock --listen-group=_gvm --max-email-attachment-size=-1 --max-email-include-size=-1 and replace it with the existing ExecStart that is in that file.

1 Like

Great to hear that you were able to figure out how to do these modifications on Kali Linux and shared this info.

The update of the gvmd.service file with that additional parameters has been basically / roughly also suggested previously: