Can't run initial scan, get Failed to find config 'daba56c8-73ec-11df-a475-002264764cea'

yes, i googled, this isn’t kali.
yes, I waited 1 hour.

GVM versions

gsad: (‘gsad --version’) Greenbone Security Assistant 21.4.3
gvmd: (‘gvmd --version’)Greenbone Vulnerability Manager 21.4.4
Manager DB revision 242

openvas-scanner: (‘openvas --version’, in older GVM versions < 11: ‘openvassd --version’)
OpenVAS 21.4.3
gvm-libs 21.4.3


Operating system:
Kernel: (‘uname -a’)
Linux scanner 5.13.0-1017-azure #19~20.04.1-Ubuntu SMP Mon Mar 7 11:34:26 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Installation method / source: guide (add-apt-repository ppa:mrazavi/gvm)
this is the third time I wiped it out and started over.
I have updated:
sudo -u gvm -g gvm greenbone-nvt-sync
sudo -u gvm -g gvm greenbone-feed-sync --type CERT
sudo -u gvm -g gvm greenbone-feed-sync --type SCAP
sudo -u gvm -g gvm greenbone-feed-sync --type GVMD_DATA

Watched the logs: tail -f /var/log/gvmd.log for something to indicate re-sync, reset of DB. nothing intelligent that I can see.
none of the ‘gvmd’ commands work.
(but I can log in, and see the feed status).
if root user or gvm, i get this in log (“gvm” or “root”: role)
md manage:WARNING:2022-03-11 18h39.06 utc:10346: sql_open: PQerrorMessage (conn): FATAL: role “gvm” does not exist
md manage:WARNING:2022-03-11 18h39.06 utc:10346: init_manage_open_db: sql_open failed

if run as postgres user, I get:
gvmd --get-users
md main-Message: 18:39:36.064: Greenbone Vulnerability Manager version 21.4.4 (DB revision 242)

(gvmd:10357): md manage-WARNING **: 18:39:36.064: Failed to open lock file ‘/run/gvm/gvm-checking’: Permission denied

(gvmd:10357): md main-CRITICAL **: 18:39:36.065: gvmd: Error trying to get checking lock

what am I missing?

Hi @scheidell and welcome to the forum :slight_smile:

that looks like an older tutorial so some of the information can be out of date or missing, and distribution packaged versions and PPAs don’t always match up exactly with our releases. Here is the guide for installing via source so you can compare to see what is needed: Building GVM 21.04 — Greenbone Documentation documentation


i am not totally unfamiliar with nessus//openvas (look at the plugins with my name on them), look at the CHANGELOG before version 2.0, so when I say I am reluctant to go back to the source path (due to needing recompiles every update), maybe you can forgive me. Yes, I know packages will be out of date, and at previous place ( tweeked EVERYTHING and built my own packages (google scheidell+hillary) for what I was working on 10 years ago. and, soon, maybe we can have a ‘nessus pro vs openvas pro’ discussion, but for now, I need to make sure it fixed that nasty qualys virtual web site bug.

FIXED: . Socket was wrong.

sudo -E -u gvm -g gvm gvmd --rebuild
Failed to connect to /run/ospd/ospd-openvas.sock.
Failed to rebuild NVT cache.
ls -l /run/ospd/
-rw-r–r-- 1 gvm gvm 4 Mar 14 14:26 /run/ospd/
ls -l /run/ospd/ospd-openvas.sock
ls: cannot access ‘/run/ospd/ospd-openvas.sock’: No such file or directory

[OSPD - openvas]
log_level = INFO
socket_mode = 0o770
#unix_socket = /run/ospd/ospd.sock
unix_socket = /run/ospd/ospd-openvas.sock
pid_file = /run/ospd/
log_file = /var/log/gvm/ospd-openvas.log
lock_file_dir = /var/lib/openvas


Good day

 I am new to openvas and experiencing the same issue as above. 

 Can someone please let me know where the config file is located to set the above. 

 I am running Kali-rolling distro and installed via the Repos. 

I would really appreciate the help as I have been googling for more than a week, and everyone says we need to update that socket, but nobody specifies which file the configs are located in :-( 

Thank you in advance.

Hi All,

thank you SO MUCH for the link above regarding the installation.

I went through that and made the relevant changes which I missed during install and all configs are now available. 

Thank you so much.

this is a nightmare. i honestly cannot believe the group over there hasn’t been able to fix this issue for some of the most popular distros. I"m having the same issue, i have tried everything and it’s still not working.

And only thing i can see coming from Greenbone is “build from source” or blaming the distros. Like,wow.


It’s absurd the time it takes to make this thing work/not work.
I was never been able to even start this thing.
Now, I start it, log in, and can’t scan anything due to this little absurd error:
Failed to find config ‘daba56c8-73ec-11df-a475-002264764cea’
Chinese to me, seems that the best solution is to completely remove this thing from my system to avoid wasting my time with software like this.

@blopa you must wait feed sync. it can take up to 2 hours


1 Like

@blopa its a stupid error message :thinking: