Cannot update feed from kali

I´ve install openvas CE on kali… evrerything ok ´till i got to sync feeds…
when i run : “sudo gvm-check-setup” i receive this:
*> sudo gvm-check-setup *
> gvm-check-setup 22.4.1
> Test completeness and readiness of GVM-22.4.1
> Step 1: Checking OpenVAS (Scanner)… *
> OK: OpenVAS Scanner is present in version 22.4.1.
> OK: Notus Scanner is present in version 22.4.4.
> OK: Server CA Certificate is present as /var/lib/gvm/CA/servercert.pem.
> Checking permissions of /var/lib/openvas/gnupg/

> OK: _gvm owns all files in /var/lib/openvas/gnupg
> OK: redis-server is present.
> OK: scanner (db_address setting) is configured properly using the redis-server socket: /var/run/redis-openvas/redis-server.sock
> OK: redis-server is running and listening on socket: /var/run/redis-openvas/redis-server.sock.
> OK: redis-server configuration is OK and redis-server is running.
> OK: the mqtt_server_uri is defined in /etc/openvas/openvas.conf
> ERROR: Directories containing the NVT collection not found.
> FIX: Run the NVT synchronization script greenbone-nvt-sync.
> sudo runuser -u _gvm – greenbone-nvt-sync.
*> *
> ERROR: Your GVM-22.4.1 installation is not yet complete!
*> *
> Please follow the instructions marked with FIX above and run this
> script again.

when i follow the instructions, i receive this:
> sudo runuser -u _gvm – greenbone-nvt-sync
> rsync: [Receiver] failed to connect to ( Connection timed out (110)
> rsync: [Receiver] failed to connect to (2a0e:6b40:20:106:20c:29ff:fe7f:d2ae): Network is unreachable (101)
> rsync error: error in socket IO (code 10) at clientserver.c(139) [Receiver=3.2.7]

i´m resolving ok:
> nslookup
> Server:
> Address:
*> *
> Non-authoritative answer:
> Name:
> Address:
> Name:
> Address: 2a0e:6b40:20:106:20c:29ff:fe7f:d2ae

any idea?

it’s still the same issue as your last topic at

you need to ensure you can connect to the server on the rsync port (873).

1 Like

The feed server is not running a http service. Only rsync. Therefore you can’t connect to ports 443 an 80. You need to try to connect to port 873. See

1 Like

i´ll try this way… thanks

thanks man!! port blocked in firewall… :grimacing:
… the problem is that i don´t manage the network… and admins allways said “all is open” and it is not obviously.
but u got to show him… I told him that next time I will break a chair on his head… literally!!
i´m not very familiar with linux, and I’ve been in this nonsense for 3 days… :face_with_symbols_over_mouth:

thanks a lot!!