WARNING: The initial NVT cache has not yet been generated

when run #openvas-check-setup --v9,have one WARNING:The initial NVT cache has not yet been generated. SUGGEST: Start OpenVAS Scanner for the first time to generate the cache.

How to sovle it.Thanks

What about doing a feed sync and start the scanner.

1 Like

First of all the openvas-check-setup script has been declared obsolete and will not be developed anymore.

If you build OpenVAS from source please please read the INSTALL files at each git repo (e.g. https://github.com/greenbone/gvm/blob/master/INSTALL) very carefully. If you did get openvas via packages often a setup script like with the kali distribution exists.

For your exact problem Lukas already answered your question. Run the sync scripts and start the scanner. For more details see https://github.com/greenbone/openvas-scanner/blob/master/INSTALL#L104

1 Like

I am sorry, but the link in the post does not work, leads into a 404.

BTW. Have the same problem. Did not get any further into insight, the scan does not show any results, the /var/log/openvas/openvassd.messages shows just start and end messages, scan finished without any result, even logs are not shown, in the full ultimate policy.
Is there any feature to force openvassd to compile the NVTs?
Any hidden switch to turn it into debug mode or -vv on the console?

BTW: Fresh install on latest kali

You need to sync the nvt information. This forum is full of content about this topic.

I guess you are using GVM 10. In this case you will find the linked instructions here https://github.com/greenbone/openvas/blob/openvas-scanner-6.0/INSTALL.md#setting-up-openvas-scanner