Vulnerability not shown on network scan

Use this category only if you have build GVM from sources or if you use packages provided by a 3rdparty repository.

Please read About the Greenbone Source Edition (GSE) and About GVM Architecture before posting.

When posting you should provide information about your environment using the following template:

GVM versions

gsad: Greenbone Security Assistant 21.4.3
gvmd: Greenbone Vulnerability Manager 21.4.4
openvas-scanner: OpenVAS 21.4.3


Operating system:
Kernel: Linux veu-bst-vs-01 5.11.0-1022-aws #23~20.04.1-Ubuntu SMP Mon Nov 15 14:03:19 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
Installation method / source: Source

Hi all

I have a question relating to a vulnerability being wither found or not.

If we run a Full and Fast Openvas default scan on a network segment we don’t get a particular vulnerability that appears if we run the scan on individual machines only.

so if i run Full and fast on server x.x.x.x the scan shows a particular vulnerability. If i run the same scan on the subnet in which this server resides it finds the same machine alive, it scans it but that vulnerability does not appear.

Any ideas?

This looks quite similar to:

A difference between scanning a single host and a network could originating from e.g.

  1. Overloaded scanner host / too little resources (e.g. CPU or RAM) assigned
  2. Insufficient redis configuration (e.g. too low max databases or clients configured, please see e.g. Hint: Redis setup / configuration for GSE/GVM/OpenVAS - Greenbone Community Edition - Greenbone Community Forum)