Unable to start ospd-openvas

Hi there,

I’m installing Openvas on an Ubuntu 20.04 VM but I’m actually stuck in the installation step quoted below (installation method/source). The OSPD-Service is stucked at the activating state with the same error code :

I only used the installation process quoted below, the gvmd and gsad are ON, without any problems, my redis socket has its permissions full opened, I don’t really know what’s the problem actually…

The ospd’s conf file :

GVM versions

gsad: Greenbone Security Assistant 20.08.1~git-fc9e55140-gsa-20.08
gvmd: Greenbone Vulnerability Manager 20.08.1~git-ac619bdd-gvmd-20.08
GIT revision ac619bdd-gvmd-20.08
Manager DB revision 233
Copyright © 2009-2021 Greenbone Networks GmbH
License: AGPL-3.0-or-later
openvas-scanner: OpenVAS 20.8.2
gvm-libs 20.8.2~git-f169c1b-gvm-libs-20.08
Most new code since 2005: © 2021 Greenbone Networks GmbH
Nessus origin: © 2004 Renaud Deraison deraison@nessus.org
License GPLv2: GNU GPL version 2


Operating system: Ubuntu 20.04 LTS
Kernel: Linux ubuntu 5.8.0-43-generic #49~20.04.1-Ubuntu SMP Fri Feb 5 09:57:56 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
Installation method / source: https://www.libellux.com/openvas/#install-gvm-20-08-from-source

Hello Romain,
My install method was different (added Kali repo to Debian, installed from Kali with apt), however I ran into the same issue.
I solved it by installing openvas (apt -y install openvas)
So, maybe you should still install openvas.

You need to take a look at /opt/gvm/var/log/gvm/ospd-scanner.log file for some more information about the error.

1 Like

Hi, there’s only one line in the log file :