Unable to Login to GSA - Unknown Error

Hi All,

Have spent the last couple days building all the latest versions from git sources and working on getting all services started successfully. The last issue I am now facing, I can’t actually log into GSA with my admin account and password OR a new user account and pass. It just comes up with a red line under the login box that says “Unknown Error”.

All log files in /opt/gvm/var/log/gvm indicated all is started OK and no errors recorded.

GVM versions

gsad --version

Oops, secure memory pool already initialized
Greenbone Security Assistant 20.08.0~git-17a736a39-gsa-20.08

gvmd --version

Greenbone Vulnerability Manager 20.08.0~git-0754740a-gvmd-20.08
GIT revision 0754740a-gvmd-20.08
Manager DB revision 233
Copyright © 2010-2020 Greenbone Networks GmbH
License: AGPL-3.0-or-later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

openvas --version

OpenVAS 20.8.0
gvm-libs 20.8.0~git-3597093-gvm-libs-20.08
Most new code since 2005: © 2020 Greenbone Networks GmbH
Nessus origin: © 2004 Renaud Deraison deraison@nessus.org
License GPLv2: GNU GPL version 2
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.



5.8.0-kali3-amd64 #1 SMP Debian 5.8.14-1kali1 (2020-10-13) x86_64 GNU/Linux

Unknown error means you are getting an unexpected error while making an AJAX request from GSA in your web browser to our web server gsad for logging in. You need to check the output of the browser console for more details. Especially take a look at the network tab and the login request.


Thanks for the reply. I have loaded up both console and network and this is the error being presented in console. Does this mean anything you can decipher further?

Loading failed for the <script> with source “”. login.html:1:1
_xhr: XMLHttpRequest { readyState: 4, timeout: 300000, withCredentials: true, … }
error: undefined
message: "Unknown Error"
name: "Rejection"
reason: "error"
stack: "e@\nvalue@\nvalue/</a.onerror@\n"
<prototype>: Object { … }
Source map error: Error: NetworkError when attempting to fetch resource.
Resource URL:
Source Map URL: main.47aa311a.chunk.js.map

I think I may have solved it, just for future reference. It appears that the issue was related to ‘gvm-manage-certs’ not running correctly last time. When looking in the web console, it was showing that login.html was allowed but other .js resources within were rejected. When I ran ‘bash -x gvm-manage-certs -a -f’ it showed the certs being successfully created but NOT able to be copied to one particular dir - /opt/gvm/var/lib/gvm/CA. Changed permissions to this dir and script was able to complete.

After restarting gsad.service the GSA site prompted a security warning for ‘unknown issuer’ but I was able to add an exception and log in successfully.

1 Like