Unable to automatically run Openvas feed update script

Hi there.

I followed this blog post online which outlines a script that can automatically update the Openvas feeds on a daily basis using cron: https://sysadmin-ramblings.blogspot.com/2017/04/update-openvas-feeds.html

After following the steps and running the script as a test, however, the script fails when it attempts to run greenbone-certdata-sync and greenbone-scapdata-sync as it throws an error, and then when it attempts to restart openvas-manager and openvas-scanner:

“Not synchronizing or updating the database since the current user is not the owner of the database”
“Updating NVT cache… failed”
“…/etc/init.d/openvas-manager: No such file or directory”
“…/etc/init.d/openvas-scanner: No such file or directory”

I’m currently logged onto the GSM command shell as admin. I tried switching to root and run the same script, but it throws the above error. I noticed that the user ‘feeduser’ owns the greenbone-certdata-sync and greenbone-scapdata-sync feeds and tried running the above lines as that user, but it continues to say that the current user is not the owner.

Any ideas on what I can do to fix this? Any help is appreciated, thanks!

Please note that most tutorials for own source/package installations (the GSE) are not valid for the appliance installations (GCE/GSM).

On the latter it isn’t necessary to go to the command line to enable / configure the feed synchronization, this is enabled by default.

Via Setup -> Feed you can enable/disable the synchronization and configure the access to the feed server.

Via Setup -> Time you can configure the time for the synchronization.

Via Maintenance -> Feed you can trigger an manual update of the feed.

Please see the following documentation for more info on this topic:


1 Like

Thanks, I’ll try this out.

1 Like