Trouble with gsa module

Hi there!

I’m trying to install OpenVas in Centos OS8. I’ve been following this tutorial and up to installing gsa modules it has worked just fine:

I do “cmake … -DCMAKE_INSTALL_PREFIX=/opt/gvm” and apparently works fine:

But it gets stucked here. I’ve tried to install the dependencies in root, using yum install -g …, but it still does not work.
Thank you very much for your help

I’ve tried to install GVM 20.08 from source with CentOS 8 and had many problems with dependencies, permissions and redis server. After the installation a had the same error messages like you (maybe a little different).

I decided to use the OpenVAS Packaging Project and installed everything in an hour. I only had problems with feed sync, because of a bad Internet connection. Everything else went smoothly.

I wrote everything down (German only) to remember the steps I made for the next attempt.

1 Like

Yes! i’ve followed your tutorial now and it has worked well all the instalation. But when i log in the GVM user interface, try to do a scan i get this error:

Failed to find config ‘daba56c8-73ec-11df-a475-002264764cea’

Any idea?

Than you very much

Did you run NVT sync successfully?

Solved! Had a problem with the firewall that has not allowing me to acces, now it runs perfectly!
Vielen Dank fur ihre Hilfe

1 Like