/tmp/ospd.sock not found

gvm: 9.0.1
openvas-scanner: 7.0.1
gvm-libs: 11.0.1


Operating system: Debian

Hello everyone,

(Sorry for my bad english)

I’m trying to implement GVM 11 on debian. Everything went well since I tried to start gvmd (by simply doing gvmd). Gvmd log created few ERROR log every minutes and say failed to connect to /tmp/ospd.sock.
I listed everything in /tmp/ but I don’t see this socket. I saw this issue can come from the location of the sock so I tried to move it to /opt/gvm/var/run/ospd.sock (with command gvmd --modify scanner … --scanner-host=/opt/gvm/var/run/ospd.sock) but it doesn’t work.
I set up everything in /opt/gvm/… , I don’t know if it comes from that.

When I try to execute /opt/gvm/ospd-openvas/build/bin/ospd-openvas, it tells this :

Does someone has already had this issue?
Thanks very much for your help !

It seems that something did go wrong during installation of ospd-openvas. You should try re-installing ospd-openvas.

When starting ospd-openvas you can specify the listening socket via -u UNIX_SOCKET, --unix-socket UNIX_SOCKET or via unix_socket in a config file (default config file is ~/.config/ospd.conf).



I have installed again ospd and ospd-openvas and now when I try to execute /opt/gvm/ospd-openvas/build/bin/ospd-openvas, I have no issue anymore. However, I still haven’t ospd.sock in /tmp/. I have also tried to put my socket in /opt/gvm/var/run, but again it doesn’t exists… :confused:

Does someone know how can I debug it ?

@Logselk did you read my comment?



Thanks for your help, I tried ospd-openvas -u /tmp/ospd.sock but this socket isn’t created. I also tried to create it in /opt/gvm/var/run/ospd.sock but it doesn’t work. I verified, I have full right on these directories.
Is there a way to debug this, for exemple via a log file ? I don’t see any log file about ospd.
In the following picture, I put everything I done during installation of ospd and ospd-openvas:

Moreover, I don’t have configuration file you are talking about :confused:
Do you see something wrong with this?

Use netstat and strace that should show you why … Mostly it´s a permission issue.,


Hi Lukas,

Thank you very much for your fast response.

I tried to execute my command with strace and I efectively have some issues like this :

A lot of error come from /opt/gvm/lib directory, I don’t exactly know how can I solve that, do you think this can come from installation issue?

You really should stick to the GCE :wink:

This is not a Linux system help board, so please do not post Images like this here, and don´t ask how to setup or debug a system here.

1 Like

Just check ospd-openvas --help for more params and defaults.

You could run ospd-openvas -L debug -f to run it with debug log in the foreground. In that case all debug messages are printed directly to the console. With this version the socket is only created after the feed is loaded. Therefore this may take a while.

And btw. there are already newer bugfix releases (ospd-openvas 1.0.1 and ospd 2.0.1).

1 Like

A post was split to a new topic: The ‘ospd-openvas==1.0.1’ distribution was not found and is required by the application