"The Scap data is required" problem in

Greenbone web interface shows “The Scap data is required”. I have installed openvas in kali linux by running these commands.
sudo apt-get install openvas
sudo gvm-setup
sudo gvm-start

but when in login in the web interface it shows this scap data missing error. When I run gvm-check-setup command, it shows that “Scap data is present”.

What to do to solve this problem ?.. Thanks in advance

1 Like

gvm-check-setup is a tool maintained by the Debian/Kali packagers. Greenbone is not involved in the development of that script. Therefore you can be sure that the tool developed by Greenbone (the web application Greenbone Security Assistant) is right about the situation.

To give some more hints. It is likely that gvm-check-setup looks for the files synced with the feed at the /var/lib/gvm directory. But only checking that these files are present is not enough. They need to be loaded by our gvmd service. The loading of the data may take a several minutes up to hours during the first time.

1 Like

It has been two days since I installed it on the system but everytime I start gvm, it is showing this error. There must be some other reason behind this problem.
I don’t know why nobody on the internet is telling the solution of this problem…?
If anybody have any idea, then please share.
What command I will have to run to fix this problem?

Did you take a look at the gvmd.log file for possible errors? It should be at /var/log/gvm/gvmd.log.

1 Like

Yes, I have checked this file. It is empty. I also checked ospd-openvas.log, there is an error
“OSPD[1289] 2021-06-30 08:54:34,206: ERROR: (ospd.server) Error sending data to the client. [Errno 32] Broken pipe”

Do this error message has something to do with this “Scap data required” problem…?

If gvmd is running which is required to be able to login into GSA /var/lib/gvm/gvmd.log should not be empty. But maybe it is due to the logrotate usage in Kali. Could you take a look at the /var/lib/gvm/ directory if there are other similar files e.g gvmd.log.tar.gz or something like that?

Could you also please paste the output of systemctl status gvmd?

1 Like

No!! there are no files in /var/lib/gvm directory. There are only two folders in this location named gnupg and report_formats, but these are empty.

Output of “systemctl status gvmd” command is given below

● gvmd.service - Greenbone Vulnerability Manager daemon (gvmd)
Loaded: loaded (/lib/systemd/system/gvmd.service; disabled>
Active: active (running) since Sat 2021-07-03 01:14:48 EDT>
Docs: man:gvmd(8)
Process: 1291 ExecStart=/usr/sbin/gvmd --osp-vt-update=/run>
Main PID: 1292 (gvmd)
Tasks: 1 (limit: 1873)
Memory: 5.5M
CPU: 152ms
CGroup: /system.slice/gvmd.service
└─1292 gvmd: Waiting for incoming connections

Oh I am very sorry! The path must be /var/log/gvm/gvmd.log of course and not lib.

1 Like

Yes, there are gvmd.log.1.gz, gvmd.log.2.gz and gvmd.log.3.gz files.
The contents of gvmd.log.1.gz are given below

md main:MESSAGE:2021-06-30 12h33.02 utc:1321: Greenbone Vulnerability Manager version 21.4.0 (DB revision 242)
md manage:MESSAGE:2021-06-30 12h33.03 utc:1322: No SCAP database found
md main:MESSAGE:2021-06-30 12h34.29 utc:1490: Greenbone Vulnerability Manager version 21.4.0 (DB revision 242)
md manage: INFO:2021-06-30 12h34.29 utc:1490: Getting users.
md manage:MESSAGE:2021-06-30 12h34.29 utc:1490: No SCAP database found
md main:MESSAGE:2021-06-30 12h34.30 utc:1494: Greenbone Vulnerability Manager version 21.4.0 (DB revision 242)
md manage: INFO:2021-06-30 12h34.30 utc:1494: Getting users.
md manage:MESSAGE:2021-06-30 12h34.30 utc:1494: No SCAP database found
md manage:WARNING:2021-06-30 12h47.45 utc:5020: update_scap: No SCAP db present, rebuilding SCAP db from scratch
md manage: INFO:2021-06-30 12h47.46 utc:5021: OSP service has different VT status (version 202106251021) from database (version (null), 0 VTs). Starting update …
md manage: INFO:2021-06-30 12h47.46 utc:5020: update_scap: Updating data from feed
md manage: INFO:2021-06-30 12h47.46 utc:5020: Updating CPEs

Hi coolnoob, I have your same problem.
Have you solved? How?
Let me know.