Test immediatly interrupted: No valid alive_test specified

I installed the latest release of GVM and I am experiencing issues with scans immediatly aborting.

The first task I run works just fine. The next day I wanted to run a different task and it aborts after a few seconds, the openvas log shows the following:

sd   main:MESSAGE:2022-03-24 08h58.07 utc:83560: openvas 21.4.4 started
sd   main:MESSAGE:2022-03-24 08h58.13 utc:83560: Vulnerability scan 1cf07456-4778-4a84-bd70-9442fbac5b4b started: Target has 2 hosts: {...}, {...}, with max_hosts = 20 and max_checks = 4
libgvm boreas:WARNING:2022-03-24 08h58.13 utc:83560: get_alive_test_methods: No valid alive_test specified.
libgvm boreas:WARNING:2022-03-24 08h58.13 utc:83560: start_alive_detection: No valid alive detection method was specified for Boreas by the user. Exit Boreas.
sd   main:MESSAGE:2022-03-24 08h58.14 utc:83560: Vulnerability scan 1cf07456-4778-4a84-bd70-9442fbac5b4b finished in 7 seconds: 0 alive hosts of 2

So I did a reinstall of everything just as a troubleshooting step, imported my database and ran a scan again: worked. Next day and the next scan: same failure as above.

I don’t exactly know where to look next, seems like noone else has had the same issue yet.

GVM versions

gsad: 21.4.4
gvmd: 21.4.5
openvas-scanner: 21.4.4
gvm-libs: 21.4.4


Operating system: Debian 10 ‘Buster’
Kernel: 4.19.0-19-amd64
Installation method / source: Building GVM 21.04 — Greenbone Documentation documentation


I have the exact same message as you and no match found.

Did you manage to solve this problem?

Not yet sadly… I was trying to look into the source code a bit more but I didn’t get that far yet… This error occurs if there is no alive test present in the preferences hash table. The preferences get managed by gvm-libs/base/prefs.c but I don’t exactly know where the alive test information would be pulled from to get inserted into the preferences. I’ll do some more digging.

Any news about this issue?

1 Like