Task queueing not working

Hi all,

I’ve found the following forum post detailing task queueing and it states, that new tasks are queued if less than 1100 MB of RAM is available.

More or less the same information can be found in the official documentation. Unfortunately the performance data are missing on my instance, which seems to be a bug already reported here on the forum.

I was not able to successfully queue any task despite low available RAM, see:

MiB Mem : 15961.8 total, 581.6 free, 5138.6 used, 10241.6 buff/cache

New tasks just start right away, and I was unable to observe the 1 minute grace period mentioned in the documentation.

I’m using the current community containers. Could this be related? Or is this an appliance-only feature?

Any help is appreciated.



by default this feature is not active https://github.com/greenbone/ospd-openvas/blob/1bc0262982f113cd4f97f4fa805db44cfe5045f4/ospd/parser.py#L183-L184
You need to adjust the ospd-openvas container to set --min-free-mem-scan-queue and --max-queued-scans to activate it.


Hi bricks,

thanks for clearing that up! The documentation reads as if this is an “on-by-default” feature, which I guess it is for the appliance.

I used an override file to extend the compose file for the community containers as follows:


I will have to run some tests to verify and maybe tune my configuration, but I can already observe the 1 minute grace period when starting scans simultaneously.


The documentation you are referring to is the documentation of our appliance and not of the community edition. Of course many many parts are the same but some details such this default are different. Especially because the “correct” settings for this specific feature heavily depends on your system (available CPUs and memory).