Start of gvmd failed

Hello together,

I hope somebody can help me.
I work with Greenbone Vulnerability Manager 9.0.0 on CentOs 8.
It worked fine, till last week. I dont know what happened, but gvmd crashed and it is not possible to start ist again.
I found in gvmd.log following error, and I dont knoe what does it mean and how I can fix it.

md manage:WARNING:2020-09-07 10h14.32 utc:2825: sql_open: PQconnectStart to ‘gvmd’ failed: could not connect to server: No such file or directory
** Is the server running locally and accepting**
** connections on Unix domain socket “/var/run/postgresql/.s.PGSQL.5432”?**

md manage:WARNING:2020-09-07 10h28.19 utc:4586: sql_exec_internal: PQexec failed: FEHLER: konnte Bibliothek »/usr/lib64/« nicht laden: /lib64/ undefined symbol: gnutls_x509_privkey_import

I have looked for this error in google, but just found this error in dependence with compilation of gvmd.
it worked already for me and I already scanned some targets with it.
Does anybody have idea what can I do?
I have searched for /var/run/postgresql/.s.PGSQL.5432 and I found one.
in this directory I can see also .s.PGSQL.5432.lock

thanks a lot.

Looks like you or your system has uninstalled some mandatory libraries (namely gnutls) which is required by the binary.

thank you for your answer. I asked my provider for it,
they found out that following libs are installed:
[root]# rpm -qa |grep gnutls

do you know which libs are required?

You have to look with ldd what external libs are needed:
# ldd /usr/lib64/ (0x0000ffffb685b000) => /usr/lib64/ (0x0000ffffb66c9000) => /usr/lib64/ (0x0000ffffb66a7000) => /usr/lib64/ (0x0000ffffb667d000) => /usr/lib64/ (0x0000ffffb65f7000) => /lib64/ (0x0000ffffb6494000)
/lib64/ (0x0000ffffb682d000) => /lib64/ (0x0000ffffb6447000) => /lib64/ (0x0000ffffb6418000)

or recompile your complete stack against the new dependencies.

I’m not familiar with the RPM world but on Debian the lib is called “libgnutls” which isn’t included in your output.

Same issue here after running system updates on CentOS 7. Now running from the atomic repo. Had an issue once before after system updates and removed all then reinstalled, but lost all of the history in the Greenbone website. All of the files shown in my output of ldd /usr/lib64/ are present. Is that the correct way to verify the external libs needed?

You need to check what libraries are dynamically linked.

That is a packaging issue at atomic, i would post a bug report there. There is nothing we can do here.


I have the same problem. I checked for gnutls on my system, and here is what I got: Package gnutls-3.3.29-9.el7_6.x86_64 already installed and latest version.

This is still valid for this issue:

Greenbone can’t help with issues in 3rdparty packages so the package maintainer is the first contact for such issues.

1 Like

A post was split to a new topic: Migrate existing GVM installation to a new host system

For the records, there is now an open issue raised for the package maintainer below. Please follow up there for more background info, status updates or similar.