SSH connect error Greenbone Enterprise TRIAL 22.04

I have Greenbone Enterprise TRIAL 22.04 installed on virtual machine from official image provided on website Greenbone Enterprise TRIAL 14 days for free - Greenbone. I have configured external connection with public IP and enabled the SSH inside Greenbone OS but can’t connect to it using IP with “connection refused” error.
Question: How to connect to Greenbone OS machine by SSH?

How long did you wait before trying to access the appliance via SSH? The internal configuration of SSH requires some time, during which it will not be available externally yet.

If the problem persists, please try disabling SSH on the appliance and then re-enabling it. Again, please wait a while after each step to let the configuration finish.

1 Like

I waited for quite a long time, about a day and tried to re-enable it and it is still not available via SSH. From Greenbone OS shell I cant see any SSH process by ps command.

We have identified a problem where sometimes the SSH host keys are not generated as expected on the Greenbone Enterprise TRIAL, which prevents the SSH service from working.

As far as I can see this problem is some sort of race condition - it does not always occur. While we are investigating a fix, the only workaround I can recommend is to try to disable and re-enable the SSH service until it works, or to download a new TRIAL appliance.


This is now fixed with the latest GOS 22.04.15 release.

Please download a new Greenbone Enterprise TRIAL 14 days for free - Greenbone to use the fixed version.