Sqlite error / manager daemon authentication error


I do have the same problem, although that in my case this also happens with non scheduled scans. Very small targets works without problems in my case, but large targets automatically end up with the sqlite error / manager daemon authentication error.

I’m using linux mint 18.3 with OpenVAS 9 bundles from mrazavi ppa.

Note that it doesn’t prevent the scans from working. You just can’t connect to the manager daemon anymore.

Also I found out the following workaroud: When it happens flush redis cache and you will be able to connect again until next scan:

redis-cli -s /var/run/redis/redis.sock flushall

This is only a workaround.

Any idea when a permanent fix will be implemented into the ppa ? This is a MAJOR bug.

Thanks !

Did you contact the author of this PPA? Greenbone isn’t responsible for nor involved in development of the packages provided by the PPA.

I just did it. But nevertheless, I wanted to highlight the fact that:

  1. Non scheduled tasks are concerned as well (at least in my case)
  2. There is a dirty workaround by flushing redis cache.


This might be a completely different issue then whats discussed here and it could be possible that this can be solved (at least the flushing Redis/stuck tasks, not the SQLite errors) by updating the Redis configuration on the host like described in Hint: Redis setup / configuration for GSE/GVM/OpenVAS

1 Like

And maybe my statement wasn’t clear enough. Because Greenbone isn’t involved in the packages you are using we don’t know which sources are used for them and aren’t aware of the configuration and settings. It’s likely the packages still contain issues we already did fix in the GCE. Therefore as @cfi pointed out your specific issue may also be completely unrelated to the issue discussed here.

1 Like

Yes, that’s perfectly possible although the symptoms are really the same. I checked my redis.conf and it’s aligned with Openvas requirements.

I’ve notified the package maintainer anyway. Let’s see if he responds. Good to know that at least there is now a fix for this.



Just FYI;
Package maintainer was kind enough to answer and provided me with an updated package, but unfortunately the problem is still here. So it may be a different issue in the end. I’m going to open a new ticket for this.


Maybe you wanna switch to a different packet vendor :wink: Or buy a appliance, then you can get support and a SLA if you use it for business.

There is no other packet vendor. This is the only option on Ubuntu, appart from building it from source. Also unfortunately the appliance model is not an option in my environment and I don’t think it’s possible to get commercial support from Greenbone unless you use their appliances or VMs.

I recompiled the latest stable version 7.0.4 source, and I confirm the problem is still there. There is definitely something wrong.

Also I would love to go to professional services with Greenbone, but unfortunately the appliance / GSM model doesn’t work in my environment. I’ve contacted Greenbone commercial service already, but they don’t have a solution, so I have to stick to the opensource version.

Still, there is a bug.

In my case it’s different, the problem happens randomly on trying to access tasks status. There doesn’t seem to be any damage though, as the scans goes on without any troubles. The interface is just not available randomly, and actually very frequently.

Is there any plan to backport this fix to openvasmd 7.0.4 ?

This is a completely different issue then the one which was discussed in SQLite error and tasks stuck (which was about tasks getting stuck / not launching if a schedule was attached).

To avoid misunderstandings / mixing different issues within one single thread i have split all related posts into a new topic.

And it seems you also had created already an existing thread about the “authentication error” below so i’m closing this thread as a duplicate.