Solving error "Failed to find config 'daba56c8-73ec-11df-a475-002264764cea'"

Hello guys. Recently I started an intership in a company, and this company wants me to learn about OpenVAS. I’m new to OpenVAS even though this is not my first time using an automatic vulnerability detector.
So the thing is I’ve been having trouble with OpenVAS since I installed it. I tried installing Greenbone Enterpriese Trial VM but Tasks kept getting stuck in “Queued”. Later, I tried installing it with Docker on a Ubuntu Server 22 machine but got problems again. The last thing I did was installing OpenVAS in a Kali Linux machine, but encountered other issue.
The thing is that I didn’t have any scan configs preinstalled and everything I did trying to get the scan configs didn’t solve it.
I’m going to show you what steps I followed, with links to other posts on this forum and with screenshots just in case you might find this topic useful, since I didn’t come across any topic solving this issue.
Can’t create a scan config (failed to find config) - Archive / Greenbone Community Edition - Greenbone Community Forum
Scan Config can’t be created - Failed to find config ‘daba56c8-73ec-11df-a475-002264764cea’ - How To - Greenbone Community Forum
Any of these pages of the forum solved the problem I was having.
So, the first thing I did was checking the log file:

As you can see I get a warning saying that there is no SCAP db present.
Again, I’m new to OpenVAS, I don’t know if this was my fault (VM crashed several times when doing updates due to RAM usage).
So the next thing I did was using these commands:

greenbone-feed-sync --type GVMD_DATA

The next command I used was this one:

greenbone-feed-sync --type SCAP

And finally this:

greenbone-feed-sync --type SCAP

Now I just had to be patient, I could already see in the log file that gvmd was getting updated:

And finally, going back to Greenbone page I can see scan configs are there!

So guys those two topics on this forum are the ones I followed, but I didn’t get any result, and afterwards with those commands I managed to solve this issue, that’s why I’m creating this topic just in case you might find this handy. But still, I won’t be able to solve your doubts because as I said, I’m new to OpenVAS, but feel free to ask me anything about the process and I will try to help you!

These are the links to the screenshots, because I can’t post more than one image :frowning:
https: //ibb. co/CtDXvhR (the other links end up with this, I can’t post more than two links neither: