[SOLVED] Can't start openvassd

I did installation of OpenVAS in the CentOS 7.5 follow the instructions of OpenVAS’s site.
But, I dont get execute the New Task, because appers the following errors:

  • (Status Code 503) Failed to start task: Service temporarily down

When I execute openvassd, appears:

  • (openvassd:2906): lib kb_redis-CRITICAL **: get_redis_ctx: redis connection error: Connection refused

  • (openvassd:2906): lib kb_redis-CRITICAL **: redis_new: cannot access redis at ‘/tmp/redis.sock’

  • (openvassd:2906): lib kb_redis-CRITICAL **: get_redis_ctx: redis connection error: Connection refused

I created the file and gived permission for Everyone, but isn’t suficient.

Can you help me?

I have had similar issues and found clearing the redis cache helped.

refer >> https://www.mail-archive.com/openvas-discuss@wald.intevation.org/msg11222.html

Command will be something like

Sudo redis-cli -s /var/run/redis/redis.sock flushall

depends where the redis.sock is located.

Thanks for help me, Geebee.

I try this command, but unfortunately it did not work.
Below is the output of the command:

[root@localhost]# redis-cli -s /tmp/redis.sock flushall
Could not connect to Redis at /tmp/redis.sock: Connection refused

Have you seen anything like it yet?


I changed the redis configuration … Instead of putting the redis.sock in / tmp I put in / var / run / redis, I circled openvas-setup again and it worked.

Thank you for your help.

1 Like

I am having the same issue and none of the help above helped me. I do a:
“ps -ef |grep redis” and its running.
but when I try to start openvassd i get the above errors.
Any additional help would be appreciated.

I can prove whatever logs/output to commands you need to see.

This is OpenVAS v-9 on Oracle Enterprise Linux.


a “running” redis doesn’t necessarily means that:

  • the redis server is providing the unix socket at the expected place
  • is providing the unix socket at all
  • no additional security measures (e.g. SELinux, wrong permissions) are in place

All of these could prevent the openvassd process to access the configured socket.

I had this issue and found that the redis serveice wasnt running fixed with
sudo systemctl start redis
sudo systemctl start redis-sentinel
sudo systemctl enable redis
sudo systemctl enable redis-sentinel

1 Like

For version 2020 also it worked
but I have putting the next:
[root@localhost]# redis-cli -s /var/run/redis-openvas/redis-server.sock flushall

Its works!

Have stuck with that in 20.08. How to troubleshoot it?
Redis server is providing unix socket:

$ lsof -c redis-server|grep sock
redis-ser 7574 root    7u     unix 0x0000000087d3ddc6      0t0 23114094 /run/redis-openvas/redis.sock type=STREAM

db_address the same:

$ cat /opt/gvm/etc/openvas/openvas.conf
db_address = /run/redis-openvas/redis.sock

Rights alright:

$ ls -l /opt/gvm/etc/openvas/openvas.conf
-rw-r--r-- 1 gvm gvm 43 Feb  6 06:12 /opt/gvm/etc/openvas/openvas.conf
$ ls -l /run/redis-openvas/redis.sock
srwxrwx--- 1 redis redis 0 May  4 11:48 /run/redis-openvas/redis.sock

What else should I check?