SNMP Credential

Hello everybody,

I’ve been trying to understand how to use SNMP credential unsuccessfully. Firstable, I’ve got à QNAP NAS where I activated de SNMP v3 with all the necessary. To be sure my configuraton is good, I checked SNMP from a PRTG server and it seems my SNMPv3 configuration is good beacuse I get information from the NAS.
Since that moment I went to my Greenbone Security Assistant V7.0.2 and I started procedure to try to scan the NAS with OpenVAS. For that I did in the order:

  1. I create a SNMP credential (the same is working with PRTG server)
  2. I create de Hosts wit the IP addresse and the SNMP credential created before.
  3. As documented here ( I create a port list with TCP:22,80,443,2000, 2443, 5060, 5061, 8080, 8443 and UDP: 67,69, 123, 161, 162, 500, 514, 546, 5060, 5061, 6161, 6162
  4. And finally I create a task using these elements and de scanner “OpenVAS Default” and Scan Config “Full and Fast”.

At the end of the scan nothing appears. It’s sure it’s me who doesn’t understand something.
I’ve tried to solve the problem searching on the net and this community forum but I don’t get it …
Anybody knows and could explain me what i’m doing bad ?

Could you please specify if you’re really using the Greenbone Community Edition (GCE) Virtual Appliance or using an own installation either build from source or installed via 3rdparty repositories?

Generally SNMPv3 requires the scanner to be build against the libsnmp library. On the GCE this is currently not available due to licensing issues. If you’re using an own installation it might be also possible that your scanner package/build is not built against libsnmp.

Hello CFI and thanks a lot for your reply.
I’m using an own installation on debian. I think you’re rigth, looking at procedure I used I don’t see any libsnmp package installed.
I’m gonna try a “apt-get install libsnmp-dev” in my current installation and I test again.
I’ll be back here to tell if it worked.

Thanks again for your help :slight_smile:

Ok, so let’s move this to the correct GSE category then. One additional note:

You’re using outdated versions of the GVM components. Please update to more recent ones listed in GVM-9 (stable, initial release 2017-03-07) ASAP. If you have further questions on this topic please create a new thread in the GSE category.

Unfortunately it doesn’t work. I’m going to install the server from scratch with the last version you show me, it’s not going to be easy but I will try.
Thanks a lot for your kindness and sorry for not placing my post to the correct category.