Severity error. Could not connect to server

GVM-11 on Ubuntu 18.04 Bionic

Login is normal. but any test is report error.

What is detail err I can see?

I can check the status of greenbone daemons with systemctl:

systemctl status ospd-openvas # scanner

systemctl status gvmd # manager

systemctl status gsad # web ui

This is the GSE (Greenbone Source Edition), not the Greenbone Community Edition (GCE) VM. Moving into the correct category.

1 Like

is it error ?

You have to take a look at the last report of the task for getting more details about the error.

where is patch details about the error ?

You are not looking at the latest report. You are looking at the task details…

can you give me a screencap?


Could not connect to Scanner…

host? or cilent?

It means the gvmd daemon could not connect to the ospd-openvas daemon. Most likely ospd-openvas is not running or listening on a different unix socket.

You are seeming to use some provided packages therefore please refer to the author of this packages.

1 Like

ospd-openvas is running.

where is config unix socket?

did you solve this problem - I have the same one :frowning:

I receive the same error. After installing GVM 11 on Ubuntu 20.04, the scan works perfect. After a restart or update, I below errors:

then error that shows “Could not connect to scanner” Is there a fix?

A fix / solution suggestion was provided earlier:

Okay i found the solution of, in my case, the problem.

I followed the installation of kifarunix :

Just do that :
gvmd --modify-scanner={replace by ID of your openvas scanner] --scanner-host=/opt/gvm/var/run/ospd.sock

You can see your openvas scanner with this command :
sudo -Hiu gvm gvmd --get-scanners

Good luck !

1 Like

This step is now also documented since a few months in the INSTALL instructions:

A post was merged into an existing topic: No Package ‘libgvm_base’ found

The resolution to this problem for me was to run gvm-setup once more. It did something with “Modifying Default Scanner” that resolved my issue.

Specifically, the order of operations that worked for me was:

  • gvm-setup (initial setup)
  • gvm-start
  • sudo runuser -u _gvm – gvmd --create-user= --password=
  • gvm-setup

As frakman1 stated, I then checked Configuration->Scanners, and then under “actions” checked “Validate” for all scanners and was good to go.


@edward2k6 Thanks for posting this information.

I have split this post from the original topic in the Greenbone Professional Edition category.

gvm-setup is a script provided by a 3rdparty maintainer in their packages and not provided / maintained by Greenbone. This script isn’t available on the Greenbone Professional Editions like e.g. the GSM or the GSM TRIAL so this solution wasn’t applicable for that category.