Setting GnuPG dir failed: No such file or directory

Use this category only if you have build GVM from sources or if you use packages provided by a 3rdparty repository.

Please read About the Greenbone Source Edition (GSE) and About GVM Architecture before posting.

When posting you should provide information about your environment using the following template:

GVM versions

gsad: (‘Greenbone Security Assistant 20.08.1’)
gvmd: (‘Greenbone Vulnerability Manager 20.08.1’)
openvas-scanner: (OpenVAS 20.8.1’)
gvm-libs: gvm-libs 20.8.1


Operating system: Kali 2021.2
Kernel: (‘Linux wfkali 5.10.0-kali7-amd64’)
Installation method / source: Built from source

I have tried to migrate from 20.08 to 21.04 but I receive the error message below when starting gvmd.

(gvmd:2371): util gpgme-WARNING **: 13:19:27.480: Setting GnuPG dir failed: No such file or directory

(gvmd:2371): md crypt-CRITICAL **: 13:19:27.480: lsc_crypt_new: can’t continue w/o a gpgme context

I can see the issue is to do with gpg, I can run gpg --homedir /opt/gvm/var/lib/gvm/gvmd/gnupg --list-secret-keys and it will list the key is there a config file or setting that needs to be changed to get this to work.

Many thanks

I have fixed the issue had an old version of gvmd in /usr/sbin and database had not upgraded to the correct version after the upgrade.

1 Like