Service redis-server@openvas.service not found

Hi everyone,

I’m installing GVM 11 on debian 9 (debian stretch). Installing openvas returns no issue but when I try to start service redis-server@openvas.service, it doesn’t found it (I installed gvm 11 on debian 10 before and it worked). After some research, I found that Debian 9 redis packet is named “redis-server” and Debian 10 redis packet is named “redis”. I so tried to install redis-server package. However, the service file /lib/systemd/system/redis-server@.service is not created, but it is created on my debian 10 installation.
I followed everything on and redis version is > 3.2.0, as say in install file.

I did this for configuration :
apt-get install redis-server then

Does someone has already had this issue or can someone tell me how to start redis openvas?

Thanks :slight_smile:

Update : I tried to create my own systemd file to start redis-server binary with configuration file as parametre.:
When starting this service (/etc/systemd/system/redis_openvas.service), I only get one issue with bind :

Moreover, the socket (/run/redis-openvas/redis.sock) is not created anymore.
I also try to launch redis-server /etc/redis/redis-openvas.conf without systemd file, only in cmd line but once again, socket is not created…

Does someone can help me? :slight_smile:

I have same issue. Any solution?

This should be no issue with Debian 10 or later.

The listed services file should at least also get the following lines: