Scanner crashes since nvt update in 2019

Since I update nvt data in february my tasks are stopped at 1% because of a scanner crash. I’ve tried to update from gvm9 to gvm10 but the issue is still here. (by the way, is there a clear description of how to migrate from gvm9 to gvm10?)
I am working on a centos75 virtual machine. I have updated every thing (yum update) and installed
I have this in gvmd.log:
openvas_scanner_read: Failed to read from scanner: Connection reset by peer

This with journalctl -xe:
openvassd[81427]: (process:82771): GLib-WARNING (recursed) **: Invalid UTF-8 passed to g_io_channel_write_chars().
Process 84112 (openvassd) of user 0 killed by SIGABRT - dumping core

And this is the message of centos:
ABRT has detected 1 problem(s). For more info run: abrt-cli list --since 1558428967
[root@openvascos75 qualif]# abrt-cli list --since 1558428967
id 7b94cabd979f5c3235b3fd0cd0e32ca673c48ce3
reason: openvassd killed by SIGABRT
time: Tue 21 May 2019 11:57:17 AM CEST
cmdline: ‘openvassd: Serving /var/run/openvassd.sock’
uid: 0 (root)
count: 2
Directory: /var/spool/abrt/ccpp-2019-05-21-11:57:17-82771

id 675e81ebcf22123d558f57e49142e7826257ab89
reason: gvmd-sqlite killed by SIGABRT
time: Tue 21 May 2019 11:43:03 AM CEST
cmdline: ‘gvmd: Syncing SCAP’
uid: 0 (root)
count: 1
Directory: /var/spool/abrt/ccpp-2019-05-21-11:43:03-80448

The Autoreporting feature is disabled. Please consider enabling it by issuing
‘abrt-auto-reporting enabled’ as a user with root privileges

Any one has a idea?

I would check your GLib and how it is compiled, it seems there are some issues with your encoding. The best would be setting your environment correct and recompile the scanner and GVMd plus all dependencies.

1 Like

Thanks for your help Lukas.
I finally succeeded.
I have installed many packages, almost every thing I could find in web pages linked to Openvas installation or glib.
Then I removed completely gvm 10 and any traces of my old Openvas 9 like /var/lib/openvas directory…
Then I flush redis database:
redis-cli -s /var/run/redis/redis.sock flushall
Then I installed again gvm 10.
Now it works. But I can’t tell which of my actions really was the one that solved it.

I suggest not to write the Redis to a persistent memory device. There is absolutely no need doing this.

Same issue here!

openvas-manager[1920]: (process:1950): GLib-WARNING (recursed) **: Invalid UTF-8 passed to g_io_channel_write_chars().

I run out of disk space when restoring the tasks.db from another machine so the DB got corrupted and/or the manager couldn’t write to the disk.