Scan does not run but no errors need some help getting this going

downloaded and installed the VirtualBox iso and set that up. got the NvT to updates. No indication that anything is wrong. Added target by IP and the alive check is set to assume its alive. Go to Task and create task to scan target and kick it off and it finishes in seconds. nothing found. Tried scanned known open targets inside my network and does the same thing no errors are being shown.

What can i do?

I have the same issue. Scans worked on previous versions. On web interface, Feed Status shows NVT, SCAP and CERT feeds are all current as of today. Create a target to a known-vulnerable box. Create a scan using that target. Log shows scan completes in 0.04 seconds. Scan results are empty.

On web interface, under “SecInfo” -> AllSecInformation (477135 of 477135), all entries in the Severity column say “N/A” except DFN-CERT-2019-0170. Perhaps this is normal? Have not paid attention before.

On web interface, under “SecInfo” -> NVTs (0 of 0), the display is empty. In the “NVTs by Family (Total: 0)” the graphic says, “No matching NVT

On web interface, under SecInfo -> CVE (118124 of 118124) the display looks normal except that all entries in the Severity column say “N/A”.

On web interface, under SecInfo -> CPDs (302036 of 302036) the display looks normal and most of the entries in the Severity column have numbers in them.

Intel NUC7i5BN - 16GB memory, 300GB Flash Drive
Ubuntu 18.04.1 LTS Server updated to most recent state
VM Engine:
Virtualbox 5.2.24 - Latest extension packs installed
VM Configuration:
2 CPUs, 2 MB memory, 20GB hard disk, internet access
GSM iso:
Installed per directions on Greenbone website. NVT’s installed.

FWIW, I was able to get Greenbone to see the full NVT set by issuing an
openvasmd --rebuild
command and then restarting the VM. I am not convinced that the system is behaving correctly as it does not appear to find a number of vulnerabilities that I know are present. But at least it does not now return an empty scan.

1 Like

This 100% worked for me! So for anyone having this issue. login to to vm via console not web. navigate to advanced, support, shell and run the command above. it took a few seconds and i was able to run the scan.

Please let me know if you are seeing anything other than positive results for only the most basic tests. Supposedly my system now has access to all the NVTs, but all I get back are some warnings about out-of-date cypher suites.

i do get mostly Cypher results but they are legit results. I am running a full deep scan and i get other things but the Cyphers appear to be most common.

Thank you. I am now also getting good results with the deep scan - forget exactly what it is called.