Rocky Linux GSE Build - ospd-openvas - incompatible nvticache

I have built GSE from the last stable version via git.
I have followed the sequential steps for a CentOS 8 / Rocky Linux installation and all component appear to building and interacting as expected.

However. When I start ospd-openvas, it runs for several minutes.
I have registered and verified a scanner, and created an admin user.
However, consistently ospd-openvas errors out after several minutes of operation with:

  File "/opt/gvm/bin/ospd-openvas", line 11, in 
    load_entry_point('ospd-openvas==20.8.5.dev1', 'console_scripts', 'ospd-openvas')()
  File "/opt/gvm/lib/python3.7/site-packages/ospd_openvas-20.8.5.dev1-py3.7.egg/ospd_openvas/", line 1485, in main
  File "/opt/gvm/lib/python3.7/site-packages/ospd-21.4.5.dev1-py3.7.egg/ospd/", line 159, in main
  File "/opt/gvm/lib/python3.7/site-packages/ospd_openvas-20.8.5.dev1-py3.7.egg/ospd_openvas/", line 484, in init
  File "/opt/gvm/lib/python3.7/site-packages/ospd_openvas-20.8.5.dev1-py3.7.egg/ospd_openvas/", line 126, in get_feed_version
  File "/opt/gvm/lib/python3.7/site-packages/ospd_openvas-20.8.5.dev1-py3.7.egg/ospd_openvas/", line 117, in ctx
  File "/opt/gvm/lib/python3.7/site-packages/ospd_openvas-20.8.5.dev1-py3.7.egg/ospd_openvas/", line 73, in _get_nvti_cache_name
  File "/opt/gvm/lib/python3.7/site-packages/ospd_openvas-20.8.5.dev1-py3.7.egg/ospd_openvas/", line 107, in _set_nvti_cache_name
ospd_openvas.errors.OspdOpenvasError: Error setting nvticache. 
 Incompatible nvticache version revision. 
Supported versions are >=11.0.

I cannot find any reference to this error in past posts. Also, it seems that nvti is intrinsic to ospd-openvas so I do not understand how there can be an ‘incompatibility’.

Any ideas? Perhaps I should not be getting a clone from ‘stable’ for ospd-openvas in order to get a compatible version to stable ospd?

Thank you for your help. Brent

GVM versions

gvmd: 21.4.5~dev1~git-680b3265-stable
openvas-scanner: 21.4.4~dev1~git-f7a9ec68-stable
gvm-libs: 21.4.4~dev1~git-ca2909e-stable


Operating system: Rocky Linux
Kernel: 4.18.0-348.7.1.el8_5.x86_64 #1 SMP Tue Dec 21 19:02:23 UTC 2021 x86_64 GNU/Linux

Installation method / source: install-gvm-21-04-on-rocky-linux-8
git clone -b stable --single-branch{gvm-libs,openvas-smb,openvas,ospd,ospd-openvas,gvmd,gsa}

Well I may have answered my own question. I cloned ospd-openvas tag v21.4.3 and built it. So far it seems to be running. That does suggest that ospd-openvas ‘stable’ is currently not compatible with ospd ‘stable’.

GitHub - greenbone/ospd: OSPd is a framework for vulnerability scanners which share the same communication protocol: OSP (Open Scanner Protocol) has been archived and contains the following description:

:warning: ospd got merged into ospd-openvas. Therefore this repository is unmaintained and will not get any further changes!

so only ospd-openvas seems to be required now.

Thank you.

Then it wouldn’t matter if ospd was compiled/installed before ospd_openvas?

ospd_openvas ‘stable’ produced stack trace error of what seemed like a compatibility problem (ospd 21.4.5 versus ospd_openvas 20.8.5)
ospd_openvas tag 21.4.3 does not have this problem.

I seem to have it working, but perhaps there is repository issue, or may be it is build documentation issue (to not build ospd). I would think that anyone trying to build GSE from stable would come across this issue.

You can’t mix generations of ospd and ospd-openvas. For example ospd-openvas 20.4.x needs ospd 20.4.x. If you use the stable branch (what will become 21.4.4 sometime) you don’t need ospd at all anymore because ospd got merged into ospd-openvas. All other versions (<= 21.4.3) need the corresponding version of ospd installed.