And now for my weekly GVM question. I deployed gvm10 under sqlite3 and over a week or so performance slowly deteriorated as scans were run and reports were imported from our old system. . I then ran the script to convert to postgres, which per the script, did run successfully. TBH though, I’m not sure if the newer database is being used. Is there a clear way to tell?
The larger problem I have today is that reports can not longer be generated by generating a PDF or scheduling an alert. We just get a timeout similar to.
A timeout for the request to url
I’m guessing the SQL Server is swamping? Any ideas on where to look on this one? the various log files aren’t showing much.
gsa: (‘gsad --version’) 8.01
gvm: (‘gvmd --version’) 8.01
openvas-scanner: (‘openvassd --version’) 6.01
gvm-libs: 1.5.32 Environment
Operating system: Ubuntu 18.04
Kernel: (‘uname -a’) 4.15.0…65
Installation method / source: source
October 8, 2019, 8:40am
Did you re-compile your GVM with the correct PSQL libraries ? If not please do so.
October 8, 2019, 10:57am
If you build from source you can check the
gvmd symlink in your sbin directory. It links to the binary used for the database backend e.g.
This seems to be sorted now. Thanks for the input gentlemen!
@jamesber, how did you fix this issue? I also get the same errors. I am using docker container from securecompliance/gvm image.
It’s a while back, but I failed to follow the instructions for postgre install. Your milage may vary dependiong on whetehr this is a new install or a migraton.
These lniks may help:
This file has been truncated.
# INSTALLATION INSTRUCTIONS FOR GREENBONE VULNERABILITY MANAGER
Please note: The reference system used by most of the developers is Debian
GNU/Linux 'Buster' 10. The build might fail on any other system. Also, it is
necessary to install dependent development packages.
## Prerequisites for Greenbone Vulnerability Manager
* cmake >= 3.0
* glib-2.0 >= 2.42
* gnutls >= 3.2.15
* libgvm_base, libgvm_util, libgvm_osp, libgvm_gmp >= 20.4
* PostgreSQL database >= 9.6
* libical >= 1.0.0
* xml_split (recommended, lowers sync RAM usage, Debian package: xml-twig-tools)
Prerequisites for certificate generation:
* GnuTLS certtool