Problem with remote connections docker

I installed GVM using the official docker containers. That worded fine. I could connect via and scan targets. I changed the docker-compose.yml inserting:

-        -

+     networks:
+       - macvlan_network
+       - default

+ networks:
+   macvlan_network:
+     driver: macvlan
+     driver_opts:
+       parent: wlan0  # Replace with your host's network interface
+     ipam:
+       config:
+         - subnet: 
+           gateway:

Now I can connect to the web interface via and start a scan, which returns 0 Targets (using the same host as a testing target, and a simple scan using the task wizzard).
I never used docker before and this set up seems rather complex to me… I hope the formating of the file contens worked this time …

Just a suggestion, but you could try to do a Host Discovery or System Discovery instead of the Full and Fast scan to determine if you can see any other devices on the network.

I tried host-discovery scan, which returned 0 Hosts, 0 Applications etc… the host machine is definitly connected to the network, i starded GVM containers via ssh … thank you for trying to help me …