Pidfile_create: failed to open pidfile: Permission denied

Everything seems fine except “systemctl start gvmd” fails with the error “pidfile_create: failed to open pidfile: Permission denied”

Everything built and installed as gvm user in /opt/gvm.

I have tried giving root write access to /opt/gvm/var/run/ (where the pid file I assume should be created) but this doesn’t seem to make any difference. I have bumped up the log levels to 128 but no other useful error shows up. Is there a way to tell where it is trying to create the pid file ?

GVM versions

gsad: (‘Greenbone Security Assistant 20.08.0~git’)
gvmd: (‘Greenbone Vulnerability Manager 20.08.0
Manager DB revision 233
Copyright © 2010-2020 Greenbone Networks GmbH
License: AGPL-3.0-or-later’)
openvas-scanner: (OpenVAS 20.8.0
gvm-libs 20.8.0
Most new code since 2005: © 2020 Greenbone Networks GmbH
Nessus origin: © 2004 Renaud Deraison
License GPLv2: GNU GPL version 2
gvm-libs: gvm-libs 20.8.0


Operating system: Fedora Core 31 Server
Kernel: (Linux nyx 5.7.15-100.fc31.x86_64 #1 SMP Tue Aug 11 17:18:01 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux)
Installation method / source:

To test, I did:
usermod -a -G root gvm

Still getting the same error
pidfile_create: failed to open pidfile: Permission denied

I did make install for gvmd-20.8.0 as gvm user, I have tried make install as root, it did not resolve the problem.

I guess this is a issue of your init-system and not GVM, i would try to debug there.

First try to start the services manually, and check with strace what user is trying to create with what permission the file.

Then use the permission system to fix it.