PDF reports problem


Tried it.
It just creates more issues with the dependencies connected to the corresponding packages.
The bugs are already logged , see post from @cfi

@flipthemouse https://web1.eng.famu.fsu.edu/~dommelen/l2h/errors.html#argex


@flipthemouse try running file againts latex syntax checker? for example: https://www.nongnu.org/chktex/


Thank you @Eero, which file exactly ?

@flipthemouse the temporary directory probably contains needed files…


@flipthemouse if possible, please provide temporary directory contents in targz so. i can take look of it?

scan of is enought


  • Current versions:
    gsad 21.4.4
    gvmd 21.4.5
    openvas-scanner 21.4.4
    gvm-libs 21.4.4
    system is Linux kali 5.18.0-kali5-amd64

  • Additional install: xmlstarlet texlive-fonts-recommended texlive-fonts-extra texlive-latex-extra

  • Enabled tracking via /usr/share/gvm/gvmd/report_formats/c402cc3e-b531-11e1-9163-406186ea4fc5/generate

  • Performed scan via WebGUI on and exported the 0-bytes file report in pdf.

  • Created tmp_folder.tar.gz from /tmp folder for analysis

Getting message: “Sorry, new users can not upload attachments.” from community.greenbone.net

Cannot attach to message

Uploaded files on files.fm , Accessible via https://files.fm/u/n8y794wyj


  • report-b1c0297c-69f4-4ab6-8219-21b863f49bda.pdf

  • tmp_folder.tar.gz
    SHA256: D0064FE79C19A2F501A034ADC7791C5D4EA890E7F3566FD9138C68047A3B1698

Link active until 26.August 2022 then delete.

Hope this helps. Thanks for your support @Eero

LL & P


After a week of troubleshooting and a full Kali reinstall, @paiva.rafael 's fix worked.
The issue that I was facing was that I was editing the latex.xsl file in the wrong directory.

I had been working in /usr/share/gvm/gvmd/report_formats/c402cc3e-b531-11e1-9163-406186ea4fc5

and not


Agree can confirm that
In my case the responsible folder was too in /var/lib/gvm/gvmd/report_formats/
There was only one subfolder having the folder
402cc3e-b531-11e1-9163-406186ea4fc5 with the latex.xsl file to edit.
Commented the line \usepackage[utf8x]{inputenc} to %\usepackage[utf8x]{inputenc}

After the reload
systemctl daemon-reload && systemctl restart gvmd.service && systemctl restart gsad.service

pdf export was again working

Thank you Magmonix , paiva.rafael and Eero

1 Like

@flipthemouse it might be wise to create good bug report on kali bug system.


@flipthemouse looks like I can repeat bug in latest kali with all patches applied.

main problem is that these files are dynamically generated. trouble comes back after gmvd sync…


1 Like

Hello, I can confirm, with this solution the problem is solved!.
Thanks a lot.

This solution works, thanks a lot.

1 Like

@kapa please note that it probably fails again after the gvmd sync.

it might be wise to chattr +i /path/file to make it read only.


Ok, many thanks again for your help. :slight_smile:

@kapa that works only on extX filesystems.


Worked for me as well! Thanks!

For tracking purposes, some further discussions about a possible workaround from GVM side has been continued here: