PDF report empty 0 B

So when i export the report in PDF it is empty i checked the latex.sxl file and i did this modification i changed \usepackage[utf8x]{inputenc} to %\usepackage[utf8x]{inputenc} and executed this command
systemctl daemon-reload && systemctl restart gvmd.service && systemctl restart gsad.service

here’s the file path
Nothing changed still the same error please help me asap i need to send the pdf report to my supervisor tomorrow

In order to understand what is going on, we need all the relevant information about your install method, the system you installed to and any modifications you made to the GVM source code or operating configuration. Thanks!


this is the installation method

Install PostgreSQL

sudo apt -y install postgresql

Add the GVM repository
sudo add-apt-repository ppa:mrazavi/gvm

Install GVM
sudo apt -y install gvm

Create the notus directory
sudo mkdir /var/lib/notus
sudo chown gvm:gvm /var/lib/notus

Update the Greenbone feeds
sudo -u gvm -g gvm greenbone-nvt-sync
sudo -u gvm -g gvm greenbone-feed-sync-legacy --type CERT
sudo -u gvm -g gvm greenbone-feed-sync-legacy --type SCAP
sudo -u gvm -g gvm greenbone-feed-sync-legacy --type GVMD_DATA

Configure the Greenbone Security Assistant web interface.
sudo vi /etc/default/gsad


I’m using a Ubuntu 22.04.4 LTS (GNU/Linux 5.15.0-97-generic x86_64) virtual machine connected via ssh. As far as i remember i did not change anything in the GVM source code nor the operating configuration.


this is an external repository with an undefined state of quality. It might be possible that the packages for our software are broken and missing specific dependencies for the report.

You could take a look at our Dockerfile for the required dependencies when using Debian as a installation base (Ubuntu should use the same or very similar packages) gvmd/.docker/prod.Dockerfile at main · greenbone/gvmd · GitHub

Otherwise you can take a look at our Greenbone Community Documentation for the supported installation methods of our software.


I checked the dependency list in the link that you provided i found that these 2 dependencies : "texlive-fonts-recommended " and “texlive-latex-extra” were missing i used these commands to check if they were installed or no

sudo apt list --installed texlive-fonts-recommended
sudo apt list --installed texlive-latex-extra

and installed them using these commands:

sudo apt install texlive-fonts-recommended
sudo apt install texlive-latex-extra

then i restarted the gsad and gvmd now i can install the pdf report and it’s not empty thank you so much for your help!


You are welcome! As I wrote these Ubuntu packages are from an external party not in touch with Greenbone at all and therefore in an undefined state of quality.

JFYI: It isn’t required to restart gvmd or even gsad in this case. It would have worked without restarts.


Thank you for clarifying the information and for your assistance! I’m still new to greenbone so replying is really helpful!