Override(s) not taken into account in GVM-11

Thanks forum for not letting new users upload more than one file so here’s a screenshot of my initial post that I couldn’t post - as one file. Get your glasses ready.

GVM versions

gsa: 9.0.0
gvm: 9.0.0
openvas-scanner: 7.0.0
gvm-libs: 11.0.0


Operating system: Linux
Kernel: 5.1.4
Installation method / source: Exherbo packages

Hi tgurr.

From which dialogue did you cut the “Übersteuerungen anwenden” radio button? This setting does exist in the edit task dialogue
ot the edit filter dialogue

Only in the filter dialogue it does what you intend to do.

To see the applied overrides, open the Report:Results view:
Web-GUI > Scans > Reports > Date of the Report > Results Tab
and enter the following in the filter field:
To make sure if the filter is actually in the state you want, check the applied filter string at the bottom left of the Report:Result view.

I got what you mean and could figure it out with your help how to work with filters. Some things I had problems with is when clicking on filter, you can make your changes and save it, but if you falsely think the first input box “Filter” is also some kind of name to name your filter you end up with a filter that displays no results.

Is there any way to specify the newly created filter as default view? Right now I’ve to select the filter again from the dropdown menu every single time I view the results.

I suppose it’s not possible to also edit the default filter or save one as default?

Thanks for your help and regards!

That’s correct, the top entry is to enter additional filter terms, not the name of the filter. Anything entered at “Filter” is used as a filter.

To set a customized filter as default filter open My Settings in GOS 6
Web-GUI > User Icon (top right) > My Settings
Click the Edit My Settings button in the icon row on the top left and srcoll down to the filters settings section.
The filter type that is applied to the Report:Results view is the Results filter. Select here your custom filter from the drop down menu and save.

Everything seems to work fine for me for the reports and tasks view, however not for the results view, there the items with the overrides still show up with the initial severity value. The other filter options like results per page are taken into account though.

When you say “results view”, I understand you mean this view:
Web GUI > Scans > Results
While this list of results indicates with an icon if an override is defined for a result, the Overrides can’t be applied in this result view. The filter term apply_overrides has no effect here.

Web GUI > Scans > Results
Overrides can’t be applied in this result view

Correct, thanks for the explanation, it’s a bit confusing since you can create a filter there as well and mark the checkbox to include overrides.

It also happens every now and then when accessing views that the filter specified as default is not applied, so you have to manually select it or logout and back in, then it usually works again.

So basically what I want is working now, thanks for all your help and time you took for responding and explaning. Maybe the few hickups I experience will be resolved in future versions.

1 Like