Ospd-openvas and gvmd service both are masked and can't start


I’m not able to start ospd-openvas and gvmd services, both service are masked. I have tried sudo systemctl unmask ospd-openvas and systemctl unmask gvmd but I have this error “unit not found”.

Masking is a state of a unit file. It’s also known as the “third level of off” (stop-1st, disable-2nd, mask-3rd). If a service is masked, it means its unit file is symlinked to /dev/null. In other words, when we mask a service, a symlink is created from /etc/systemd/system to point /dev/null. This makes it “impossible” to load the service, even if another enabled service requires it.

Reference From

To unmask a service run:

systemctl unmask name.service

See: https://www.howtogeek.com/216454/how-to-manage-systemd-services-on-a-linux-system/

If you still cannot start the service try running journalctl -xe which should indicate why.

1 Like

Hi @rippledj ! Thanks, It’s OK now. After using systemctl unmask name.service. Another erreur appeared : unit not found.

The matter was because the whole installation was performed as root. I found some of files were under root privilege. As It is a lab, I restarted the installation by following exactly the guide Building 22.4 from Source - Greenbone Community Documentation.

1 Like

Yes, you will find that Greenbone architecture depends heavily on user configuration. During installation, a _gvm user is created similar to how Apache creates an apache (or www-data) user, or the mysql user for MySQL. This user’s permissions are also important for the normal function of the application.

These user permissions allow Greenbone to employ some configurations for security such as immutable log files, and more to protect the installation and underlying subsystem.

Glad it worked out for you.

1 Like