Ospd error

I am a new user of the GSE and I am new here on the forum.

GVM versions

gsad: Greenbone Security Assistant 20.08.0~git
gvmd: Greenbone Vulnerability Manager 20.08.0


Operating system:
Kernel: Linux raspberrypi 5.4.51-v7+ #1333 SMP Mon Aug 10 16:45:19 BST 2020 armv7l GNU/Linux
Installation method / source:

I installed ospd and ospd-openvas from the latest master branch but I am getting the following error

Traceback (most recent call last):
File “/opt/gvm/bin/ospd-scanner/bin/ospd-openvas”, line 8, in
File “/opt/gvm/bin/ospd-scanner/lib/python3.7/site-packages/ospd_openvas/daemon.py”, line 1338, in main
daemon_main(‘OSPD - openvas’, OSPDopenvas)
File “/opt/gvm/bin/ospd-scanner/lib/python3.7/site-packages/ospd/main.py”, line 161, in main
File “/opt/gvm/bin/ospd-scanner/lib/python3.7/site-packages/ospd_openvas/daemon.py”, line 486, in init
File “/opt/gvm/bin/ospd-scanner/lib/python3.7/site-packages/ospd/ospd.py”, line 253, in set_vts_version
‘A vts_version parameter is required’, ‘set_vts_version’
ospd.errors.OspdCommandError: A vts_version parameter is required

Anyone can comment what could be wrong?

Please see the info about the master branches below. You also can’t mix e.g. the master branch of ospd-openvas with e.g. the gvmd 20.08.0 release. Please keep your setup at the latest stable releases 20.08.

1 Like


Thanks for your reply. The reason why I installed the master branch for ospd, and ospd-openvas is that when I installed the ospd-20.08 and ospd-openvas-20.08 and start a scan I get host is dead for every task and every target. Although, I can ping the hosts and there is no firewall etc this is just a simple home wifi network. Also, I get the host is dead even if I select consider alive target scan config.

So, based on following I tried to install the master branch

But now I get the error as I mentioned in my first message. So, now the question is if I cannot mix the master branch with 20.08 how can I get around with the host is dead for every target.


Hi, sory im late, but i fixed it for myself with the checkout of a certain branch and build an .egg-package by my own.

In pull request #334 the issue you mean was fixed:

I checked out the belonging revision.
Fixed the setup.py install_requires=[‘ospd>20.8.0’, ‘redis>=3.0.1’, ‘psutil’, ‘packaging’],
and did a bdist_egg to build the package on my own.

Replaced the egg package with the old one in /opt/atomicorp/lib/python3.6/site-packages on the machine.

It’s not the most beatiful solution but it works!
Before i was waiting over weeks for help.