OpenVAS setup rsync stops

I’ve tried through the ISO / VM from greenbone as well as through the Kali VM setup - both have the same results. When I run openvas-setup it gets to the step 1/2/3 for updating the feeds and the rsync process just stops halfway through step 2 (updating scap data). Not timing out, not failing to connect to the server, and not right at the start (which might lead me to believe it’s a firewall or networking problem, but always (as far as I can see) on the file nvdcve-2.0-2016.xml.

If I hit ctrl-c it will continue through step 3 and that completes just fine. When I try to run a scan though it always fails with the host being unreachable (even if I can ping it from the console). I’m assuming these are two different issues, but I’m hoping someone can help me with this one first. Here’s a screenshot of what it looks like:

And a log of all the output from openvas-setup:

Note: This is without a key of any kind, just trying to use the community edition to see if it works.

Anyone got any ideas or troubleshooting?

SCAP does take some time, so please wait and check the xsltproc is taking CPU time. If so you need to wait until it´s finished.

Right now this has been running since I posted here 4 hours ago, there is no xsltproc in the process list at all, and it is still sitting at the same place as the screenshot in the middle of the rsync.

If 4 hours isn’t enough time, in the past I’ve left it overnight, with the exact same results. The machine is a vm running on the mac with vmware fusion, the current Kali Linux vm. The virtual hardware is 4 cores and 2G of ram. I know that XML and XSLT can take a while, but this seems to be the rsync process that’s stuck, not the processing afterwards (though that’s just a guess based on the output to the screen.

I will leave it overnight again though if you think it’s a time thing.

Please allocate at least 4GB RAM and configure 4GB of swap to get it running. Please note this board is not for Kali support so please get back with the Kali Maintainer or Kali support resources.

1 Like

I’ll give it a bit more ram. Like I said this was the same situation as it was with the official VM, but I will re-install that and come back here. The process (now 19h later) is sitting in the exact same spot with the same file FYI - terminal not frozen or anything.

I am facing same issue

15,269,888 11% 926.30kB/s 0:02:05

last 3 days nvdcve file not sysnc
stop when nvdcve size reached at 11%
kindly help

I am using centos 7
Swap 4GB

I need your Source-IP and Source-Port as well the exact time in UTC, then i can look into it. You need to hurry we only log for 48h.

Please note, only one TCP-SYN is accepted from any public IP address , our firewall does not allow two or more session per source IP address to be fair to all community users. IPv6 is usually not so crowded like IPv4 for syncing the feed. We have as well a global session limit …