OpenVAS Scanner interrupted at 0%

I think is a problem related with the python encoding UTF-8

I will repeat all again, but this time, setting the language to “en_US.UTF-8” from the begining. I was using “es_CU” wich maybe, wich appears to not be compatible. I will post the results later

Well, the error persist after the changes

GLib-WARNING (recursed) **: Invalid UTF-8 passed to g_io_channel_write_chars().

I hope to get the attention of someone here :confused:

Maybe you have a glib issue, i would compile glib and GVM with debug symbols and run it with GDB so see what “invalid UTF-8” is written to your IO channel.


Hi Lukas. Thanks for your attention. So…it looks more like a glib issue than a bug of ospd-scanner? If it so…then it might be a problem related with glib library in Debian Buster repos.

Would you mind to take a look at my procedure linked in the first post? Just for be sure that i am installing the ospd-scanner in the right way. Is in spanish, but you only need to see the command line procedure.

I am sorry, but if you compile it, you need to debug it.

We can´t support any community self compiled system or any uncoordinated integration. Please try if the GSM Trial is working, and then you need to fix your self build system or use a Greenbone Image.

If you have questions to packets or operating systems besides GOS you need to ask your OS vendor for support.

Ok. Thanks for your answer Lukas. Is there any ensurance that GVM 21.4.0 compiled from source works on Debian Buster 10.9?

In the regards that it compiles and runs on it.

1 Like

Hi bricks, thanks for your answer. Then I would have to try harder and do my best. I will test on Ubuntu Focal next time. If the error continue, then it will be a procedure error from my part. If not…well, it could be something related with Debian Buster.


PS: GVM is running on my system, but cant do a succefull scan…wich is not the same of running

Hi, I don’t know if this can help, but some months ago I used the guide below to build GVM (20.08 at that time) on a Debian system and it was very useful.
Maybe you can cross-check your instructions against it and, in case of discrepancies, you could further investigate those aspects…

Hi filo, thanks for your help. I checked that tuto…but it has some issues inside. yarn installation is different now, and there are errors in the redis and gvm services startup scripts. But I will check it again.

1 Like

Hi filo. I already finished this step by step ( and it has multiple errors related with ospd.sock and permissions with the reading of some files. Beside…the redis configuration service has the wrong path. The ospd and ospd-scanner are not compiled in this case. Multiple errors with python, possible that the tuto mix differents branchs of gvm sources.

Its very difficult to find a good HOW TO, updated to recents versions, even in the official docu.
I will keep trying…it has to be done someday

The one below should work quite well even for 21.04 (only the github branches needs to be changed from 20.08 to 21.04):

Hi cfi. I have tried installing Kali in Debian Buster (via Kali repos) and it also happened the same error. It appears that is something related with Debian 10. I am trying now installing Kali Linux, it should work. I will also test with ubuntu focal.

PS: That link is also outdated. My procedure is a mix between that one and the kifarunix procedure

I can’t confirm this as i had exactly used that tutorial to install a GVM 21.04 installation from scratch.

on Debian Buster 10.9?

Yes, on Debian Buster 10.9 (haven’t tested the recently released 10.10 yet) as well as on Debian Testing.

Well is something really strange. I did a fresh install on 10.9, to avoid my 10.9 pre-configured template, and it happened the same. As I said before, I will test with kali Linux, via apt, wich uses GVM 21.4.0 and later with Ubuntu Focal via source.

Hi cfi. I have installed Kali Linux 2021.1 with GVM 21.4.0 via repositories and guess what…I get the same error after run the scan

Jun 22 11:35:34 gvm ospd-openvas[2896]: (process:2896): GLib-WARNING (recursed) **: Invalid UTF-8 passed to g_io_channel_write_chars().

After I downloaded all the feeds and configured de import owner, I did the next few steps:
1-Enter the GSA
2-Configure the timezone
3-Create the target
4-Create the scan task pointing to the target
5-Run the scan

gvm-check-setup 21.4.0
  Test completeness and readiness of GVM-21.4.0
Step 1: Checking OpenVAS (Scanner)...
        OK: OpenVAS Scanner is present in version 21.4.0.
        OK: Server CA Certificate is present as /var/lib/gvm/CA/servercert.pem.
Checking permissions of /var/lib/openvas/gnupg/*
        OK: _gvm owns all files in /var/lib/openvas/gnupg
        OK: redis-server is present.
        OK: scanner (db_address setting) is configured properly using the redis-server socket: /run/redis-openvas/redis.sock
        OK: redis-server is running and listening on socket: /run/redis-openvas/redis.sock.
        OK: redis-server configuration is OK and redis-server is running.
        OK: _gvm owns all files in /var/lib/openvas/plugins
        OK: NVT collection in /var/lib/openvas/plugins contains 69767 NVTs.
Checking that the obsolete redis database has been removed
Could not connect to Redis at /var/run/redis-openvas/redis-server.sock: No such file or directory
        OK: No old Redis DB
        OK: ospd-OpenVAS is present in version 21.4.0.
Step 2: Checking GVMD Manager ...
        OK: GVM Manager (gvmd) is present in version 21.4.0.
Step 3: Checking Certificates ...
        OK: GVM client certificate is valid and present as /var/lib/gvm/CA/clientcert.pem.
        OK: Your GVM certificate infrastructure passed validation.
Step 4: Checking data ...
        OK: SCAP data found in /var/lib/gvm/scap-data.
        OK: CERT data found in /var/lib/gvm/cert-data.
Step 5: Checking Postgresql DB and user ...
        OK: Postgresql version and default port are OK.
 gvmd      | _gvm     | UTF8     | C.UTF-8 | C.UTF-8 |
        OK: At least one user exists.
Step 6: Checking Greenbone Security Assistant (GSA) ...
Oops, secure memory pool already initialized
        OK: Greenbone Security Assistant is present in version 21.04.0~git.
Step 7: Checking if GVM services are up and running ...
        OK: ospd-openvas service is active.
        OK: gvmd service is active.
        OK: greenbone-security-assistant service is active.
Step 8: Checking few other requirements...
        OK: nmap is present in version 21.04.0~git.
        OK: ssh-keygen found, LSC credential generation for GNU/Linux targets is likely to work.
        OK: nsis found, LSC credential package generation for Microsoft Windows targets is likely to work.
        OK: xsltproc found.
        OK: The password policy file at /etc/gvm/pwpolicy.conf contains entries.

It seems like your GVM-21.4.0 installation is OK.

In the followinf lines you could see that I am using GVM 21.4.0:

 dpkg -l | grep gvm
    ii  gvm                                           all          remote network security auditor - metapackage and useful scripts
    ii  gvm-tools                             21.6.0-0kali1                   all          Remote control the Greenbone Vulnerability Manager
    ii  gvmd                                  21.4.0-0kali2                   amd64        Manager Module of Greenbone Vulnerability Manager
    ii  gvmd-common                           21.4.0-0kali2                   all          architecture independent files for Greenbone Vulnerability Manager
    ii  libgvm21:amd64                        21.4.0-0kali1                   amd64        remote network security auditor - shared libraries
    ii  python3-gvm                           21.5.2-0kali1                   all          Greenbone Vulnerability Management Python Library (Python 3)

The error occurs with “Full and fast” scan config

These setups work:

Well you are using open source for free. So you have pains of opensource. If you need silver bullet you have to pay for it. In this world where is no such thing as 100% free. You pay in time or money or different currency it is up to you which one you willing to pay.


You are doing a mistake, we think free as Freedom and not free as beer. Your post show that you are not aware of the concept of Open Source. GVM is free software and able to do complex setup. The source is available and gives everyone freedom. If the user can´t work with a uncoordinated integration or compile it self, the User can always use the community edition.

Support and GSF is still only available for paying customers.