Omp "failed to acquire socket"

Hello there,
i hope this has not been posted before. I am running OpenVAS9 on Ubuntu Bionic. I tried to create a user with the following command: omp --username xxxxxx --xml=’<create_user>demodemo</create_user>’

after i entered a password the output is: " Failed to acquire socket".

How can i solve this? I dont understand whats preventing to get a socket.

Thanks and best regards!


Do You have openvas-scanner and openvas-manager services started?
Try this command:
systemctl start openvas-manager
And try again

Hi mark0w,
thanks for your reply.
yes all the relevant services are running, restarted them, no success

i solved by simply saying the manager has to listen at on port 9390
“openvasms -a -p 9390”

still i get this error when i try to reach openVAS from my nagios side. Has anyone an idea why this error “failed to acquire socket” occurs, everytime i try an omp command from my nagios?

best regards

I just want to note that you are using a heavily outdated version of our software. See


1 Like

@bricks Thank you for the information, i will update my system and go for GVM11.
I took a look about chapter 18 “connecting GSM to other system”, i think this is what i need exactly to get openVAS connected to my nagios system (check_mk)?

best regards

We released GVM 20.08 yesterday

Sorry I don’t know much about the integration. I’ve just found in our manual.