No options to download report from Report Format GCE container

Hello community,

I just installed the Greenbone Community Edition from documentation on the official site and it worked well, however two days layer I’m unable to download a report (any format) the report format field is empty as shown in the image below

The scan worked well because I can see the results from the GUI but when I try to download it there’s no option to choose, this was working fine two days ago when I just installed it and I was able to download from PDF format and CSV.

I also checked on the GUI that the report formats are configured (image below)

Can you guide me where start looking?

Really new at Greenbone, and I was following the logs with the following command but couldn’t see anything related to it

docker-compose -f docker-compose.yml -p greenbone-community-edition logs -f

Thanks for your suggestions

Seems that the feed sync process has not completed or the database container was not downloaded properly.

I would follow the Greenbone Community Edition Docker containers workflow instructions to download the feed containers again and then put the containers backup:

docker compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition pull notus-data vulnerability-tests scap-data dfn-cert-data cert-bund-data report-formats data-objects
docker compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition up -d notus-data vulnerability-tests scap-data dfn-cert-data cert-bund-data report-formats data-objects

You want to see this message in the logs:

Report format XML (a994b278-1f62-11e1-96ac-406186ea4fc5) has been created by admin

Maybe you shut down the containers before these steps were completed.

Thanks for the suggestion…the log should it be seen on what container? I see 7 containers: greenbone/ospd-openvas:stable, greenbone/gsa:stable, greenbone/gvmd:stable, greenbone/notus-scanner:stable, greenbone/redis-server, greenbone/pg-gvm:stable, greenbone/mqtt-broker

One thing that I forgot to mentioned before was that, when checking logs on the container, I see on the container greenbone/gvmd:stable, the following info

I stopped the containers, did the pull and started them again

The message that I have to see is after I execute a scan? or should just be seen after the pull and start the containers again?


This section of the Community Edition Docker container documentation explains how to start a process to output the container logs:

To get a continuous stream of the log output of all services, run the following command:

docker compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition logs -f

If you want to store them to a file rather than output to stdout you can use something like this:

docker compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition logs -f > /path/to/your/outputfile.txt

Alteratively you can execute the bash shell for a specific container to examine it’s logs (in the /var/log/gvm directory).

docker ps
docker exec -it [container_name_or_id] /bin/bash

I couldn’t find this on the log, when trying to find anything with “XML” on the log the only result I have is the following:

scap-data_1 | The dictionary is provided in XML format and is available to the general

The steps involved where

  1. Stop the containers
  2. Execute the pull
  3. Bring the containers up again
  4. Wait until the feed is with current status on each type
  5. Execute the scan and let it finish
  6. Check the logs
  7. Still report can’t be download it on any format

Thanks for your suggestions!

:thinking: well, perhaps the problem is in GSA rather than the actual GVMD_DATA feed. You could try pulling all the containers again, or just pulling the gsa container again.

docker compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition pull
docker compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition up -d

Maybe @bricks can weigh in on this… Can it this because the report_formats volume is not running, but the database is populated, or is caused by something else?


if you have a list of report formats at the report formats page you should get the same list of report formats in this input selection box. At least you can check it by adding active=1 and trust=1 to the filter box at the report formats page.

Otherwise you need to take a look at the the reponse for a /gmp?token=XXX&cmd=get_report_formats&filter=active=1 and trust=1 rows=-1 first=1 request in the network tab of your browser inspector.


Thanks @JosephL for the response, I have executed the pull (for all containers and bring them up again) but same result

@bricks here is what the browser inspector returns


I have modified with the params indicated in your response**&trust=1&rows=-1&first=1&filter=active=1**%3Dhml%20rows%3D100%20min_qod%3D70%20first%3D1%20sort-reverse%3Dseverity&report_id=53bb2e1d-3d4b-4204-a17f-75b945626e64

but I have the following result on the browser

As you can see in the URL (&cmd=get_report) and the response (<get_report>), the request you picked queried for a report and not for report formats.

If you want to make that request with your browser itself, you can use http://<yourGsaAddress>/gmp?token=<yourToken>&cmd=get_report_formats, but the response won’t be nicely formatted. It would look roughly like that:

On a side note, even if your GSA instance is not public-facing, I’d discourage posting tokens (or anything else used for authentication) online.

1 Like

Thanks for the suggestion. Yeah, the result is similar to your image, however the idea was to be able download the PDF for a report…

Don’t know what happened, I installed another instance with same procedure and it’s working fine…the only difference is that in the original container I added a certificate for https without warning and it runned fined for 2 days, then i just stopped showing the options to download report

Thanks for the suggestions and time!

Do you have any browser plugins that would block? Can you try clearing your browser cache and trying again?

1 Like

Nope…I’ve tested on 3 different browsers (incognito) from 2 different PCs

Do you have a WAF such as CloudFlare that modifies your request cookies?

1 Like

To remember my message you need to take a look at the response of


1 Like

Hey @JosephL … no WAF, it’s all internal and in the same subnet, not even a firewall in the middle

Hey @bricks … attaching screenshot…I see the reports format when typing cmd=get_report_formats