Nginx reverse proxy

There are already a few topics on this across the forum, but I’ve not found one that gives a clear answer. I’m trying to access gsad behind a reverse proxy. When I access it directly, it works fine, but through the reverse proxy, I only get a blank white page. The source of the page is there, and I get the title for the page and the site icon, but nothing else. I’ve been though a raft of different options for nginx, but nothing changes. I’ve seen references to others who say are they are using it, so I ‘assume’ it works.

Can anyone share a working nginx reverse proxy config for gsad ?

@immauss take look of my nginx ssl examples:


Note that {{ variable }} is ansible variable replacement, so you need to put something on it.



Thank you!!

Turns out, this was totally my fault. There was a block in my config that had carried over from a previous implementation. It was a location for “/static” which gsad uses. I realized it after checking the browser console and seeing the 404 errors looking for things in “/static”.