"New Scanner" icon missing

I set up a fresh server (Ubuntu 22.04.01) and did a fresh install of the Greenbone Security Assistant Version 22.4.0.
As the topic title sais, there is no “new scanner” icon available:

I tried to reinstall everything (including the server it is running on) but still the same issue.
Also looked for missing permissions but everything looks just fine to me.

Can somebody help me with this?

With 22.4 the support for OSP scanners (not meaning ospd-openvas) and GMP scanners/sensors has been removed. Only these two scanner types could be created via the UI. Therefore the “New Scanner” dialog isn’t available anymore.


Hi bricks,
thank you so much for your reply.

So this means there is no option to add external scanners anymore? wow…

No that’s not what I wrote. You still can add new scanners via the gvmd --scanner-* commands and remote ospd-openvas scanners are still used in our products as sensors.


I ment the ui feature, makes it more complicated for people not familiar with commandline.
Already found out it works with gvmd.

Is this only on the community edition or also enterprise?

The enterprise version has a terminal UI for administration purposes. For adding sensors (remote scanners) it was always required to add the scanner via this terminal UI. We just removed legacy code paths in the UI.


Thank you for your help bricks! :slight_smile: