Missing GVM_DATA in GSA

Hi everyone,
Today i update my gvm from 21.04 to 22.04
I got a Problem with my GVM DATA.
In /var/lib/gvm/data-objects/gvmd is all the data for 20.08, 21.04 and 22.04
But on the Web Interface is still no data… The compliance guidelines, port lists, report formats and scan configurations are empty.
It seems like the GSA don’t use this data in var/lib/gvm/data-objects/gvmd.

Did you run the feed sync script already? What’s you installation method?

1 Like

I trying
rsync -avrP rsync://feed.community.greenbone.net:/data-objects/gvmd

Instalation with sudo apt install gvm after that reinstall postgre 13 to 15
after that updated feed

still tried the solution from this page

sudo docker-compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition \
    exec -u gvmd gvmd gvmd --rebuild-gvmd-data=all
service "gvmd" is not running container #1

I am confused. Which installation method did you use? apt install gvm hinted me to a Debian based package installation like Kali. But sudo docker-compose ... is for a container based installation. For me it seems you are just running some random commands found somewhere the internet.

1 Like

Yes, I did try everything I could find, but in the case of docker, I didn’t know it was used when installing the base container. I use Kali

ok kali. You should try to run sudo -u _gvm greenbone-feed-sync --type GVMD_DATA. Afterwards successfully downloading the files, you can trigger re-building the data with sudo -u _gvm gvmd --rebuild-gvmd-data=all.

1 Like