Login loop

Hello there,

I have the same issue like here (no response)

My installed version:
GVM 22.5 from packages on Debian 12

In /var/log/gvm/gsad.log, I have :
Authentication success for ‘admin’ from …

I cleared all cookies, to be sure… :slight_smile:

Here is the output of gvm-check-setup

gvm-check-setup 22.5.0
  Test completeness and readiness of GVM-22.5.0
Step 1: Checking OpenVAS (Scanner)...
        OK: OpenVAS Scanner is present in version 22.7.5.
        OK: Notus Scanner is present in version 22.6.0.
        OK: Server CA Certificate is present as /var/lib/gvm/CA/servercert.pem.
Checking permissions of /var/lib/openvas/gnupg/*
        OK: _gvm owns all files in /var/lib/openvas/gnupg
        OK: redis-server is present.
        OK: scanner (db_address setting) is configured properly using the redis-server socket: /var/run/redis-openvas/redis-server.sock
        OK: the mqtt_server_uri is defined in /etc/openvas/openvas.conf
        OK: _gvm owns all files in /var/lib/openvas/plugins
        OK: NVT collection in /var/lib/openvas/plugins contains 86936 NVTs.
        OK: The notus directory /var/lib/notus/products contains 446 NVTs.
Checking that the obsolete redis database has been removed
        OK: No old Redis DB
        OK: ospd-openvas service is active.
        OK: ospd-OpenVAS is present in version 22.6.0.
Step 2: Checking GVMD Manager ...
        OK: GVM Manager (gvmd) is present in version 22.9.0.
Step 3: Checking Certificates ...
        OK: GVM client certificate is valid and present as /var/lib/gvm/CA/clientcert.pem.
        OK: Your GVM certificate infrastructure passed validation.
Step 4: Checking data ...
        OK: SCAP data found in /var/lib/gvm/scap-data.
        OK: CERT data found in /var/lib/gvm/cert-data.
Step 5: Checking Postgresql DB and user ...
        OK: Postgresql version and default port are OK.
 gvmd      | _gvm         | UTF8     | libc                  | fr_FR.UTF-8     | fr_FR.UTF-8  |            |              |
        OK: At least one user exists.
Step 6: Checking Greenbone Security Assistant (GSA) ...
        OK: Greenbone Security Assistant is present in version 22.06.0~git.
Step 7: Checking if GVM services are up and running ...
        OK: gvmd service is active.
        OK: gsad service is active.
Step 8: Checking few other requirements...
        OK: nmap is present.
        OK: ssh-keygen found, LSC credential generation for GNU/Linux targets is likely to work.
        OK: nsis found, LSC credential package generation for Microsoft Windows targets is likely to work.
        OK: xsltproc found.
        OK: The password policy file at /etc/gvm/pwpolicy.conf contains entries.
Step 9: Checking greenbone-security-assistant...
        OK: greenbone-security-assistant is installed

It seems like your GVM-22.5.0 installation is OK.

Any idea?
Thanks a lot

Hi PPCM, and welcome to the Greenbone community forum,

When you say GVM 22.5 from packages on Debian 12 do you mean the native Debian install packages using apt install gvm ?. Or do you mean from the source code packages?

Did this happen immediately after installation or was it working ok for some time? What browser are you using? The other thing that comes to mind is to ensure you have JavaScript enabled and check for any extensions or security settings that may interfere.

Looks like your install method was using the Debian native package. Although the gvm-check-setup reports everything is OK, there still may be an issue.

I suggest reporting the bug at the Debian Bug Tracking System

Finally, I waited a new version of GVM 22.8, and now no problem, the installation is done correctly
Thanks for your help

1 Like