Include all open port on report

I am discovering Openvas and I am personally very happy with this solution.

Nevertheless, I discover that the generated PDF report does not include all the open port on my targets.
Report only show ports concerned by CVE (For example SSH is not displayed)

Is there a way to display all open ports in the report?

Thanks for your answer

roughly the same topic (including the solution) is discussed here:

Thanks for your reply.

I try to set the Silent Preference to No. The problem is that I don’t have the possibility to edit the tag (no edit button).


To go on this menu : SecInfo > NVT

Maybe i’m not in the good menu ?

You can’t edit pre-defined scan configs like the “Full and Fast” ones or Scan-Configurations which are already in use. Please see the following documentation on how to create an own / new config where you can configure this:

1 Like

Apologies for reviving this old thread, but it is still relevant.

I created a new Scan Config and did the following:

  1. Opened up the “General” NVT family
  2. Edited “Checks for open TCP ports”, set “Silent” to “No”. Saved.
  3. Edited “Checks for open UDP ports”, set “Silent” to “No”. Saved.
  4. Made sure both NVTs had checkmarks in the “Selected” column.
  5. Made a new scan using this Scan Config and scanned a target.
  6. The report shows “2 of 11” on the Ports tab.

Still having difficulty seeing all open ports in the report. Any ideas?

This should show that there are some additional entries in the reports which are currently filtered out.

Adjusting the Filter Parameters to e.g. show Log level entries of the report should show them.

What filter string can I use to show Level level entries? I couldn’t figure it out from the documentation link.

Edit: it seems like a filter of “level=log,hml” works. Thanks!

Editing the filter and clicking on the “Log” checkbox in the Severity (Class) shown in the Fig. 8.10 Adjusting the filter screenshot of the posted documentation is another alternative.