How to set path to gvm-tools.conf and apply

i followed your guide to install gvm 21.4.4, thank you for publishing the setup.
Now i came to the point where i want to communicate with gvmd through GMP.

At first i verify if the connection over my socket works:

gvm-cli socket --socketpath /run/gvm/gvmd.sock --xml "<get_version/>"
<get_version_response status="200" status_text="OK"><version>21.4</version></get_version_response>

i created the path ~./config/gvm-tools.conf and defined credentials and addresses for gmp and unixsocket so i dont have to give these informations in my later commands.



But it seems gvmd does not look into my gvm-tools.conf.
gvm-cli socket --xml "<get_version/>" ERROR:gvmtools.cli:Socket /var/run/gvmd.sock does not exist
I dont know why gvmd looks into /var/run/gvmd.sock, i think its a default setting.
However, i think it does not work because i didnt tell gvmd where my config is? I didnt apply anything, so i am wondering how i can do that.

I tried things like this to set a path to my config since --config requires a connection type.
gvm-cli socket --socketpath /run/gvm/gvmd.sock --config=/home/dvzadmin/config/gvm-tools.conf
but no success.

Can someone help me with setting this path to my config?

best regards


Some things to try/check.

Remove the equal sign (=) for --config declaration, so,

–config=/home/dvzadmin/config/gvm-tools.conf goes to
–config /home/dvzadmin/config/gvm-tools.conf

Also, from testing, make sure the password is unquoted. We tried with single quotes and it did not work properly.


1 Like