How to set new admin password when using OpenVAS via docker container?

Hey people. I’m first timer with OpenVAS scanner and I’m currently using it via docker-compose container, following the official documentation:

Question is, how should I reset the default admin credentials? I tried entering the container below and executing the following command: gvmd --user=admin --new-password=new_password but this change, while accepted, does not apply.

My question is, which container should I use and how can I change the default admin password, if what I’m doing is incorrect.

Thank you.

Hi, please take a look at the following section in the docs Greenbone Community Containers 22.4 - Greenbone Community Documentation


Hi and thank you for the reply. While the command was accepted, it did not apply. I am still able to log in to the webpage using the same credentials.

Could be an issue with special characters conflicting in the bash shell? Other services such as MySQL and Docker also have issues with special characters in passwords.

Otherwise, you can reset a user’s password from the user setting page. The link to the user settings in in the top right corner with the user icon → Settings.

Screenshot 2023-08-14 at 3.43.08 PM

Then change the password within the edit dialog box. The edit settings icon is in the top left corner:


Dear Lord, how did I missed this!

Thank you for the help, I just can’t get why is this recommendation not the “default” way of changing the password. In the documentation and forum posts, all I see is changing it via the CLI, which with docker at least is a pain in the butt.

Anyway, thanks a lot. Closing this out.