How can the timeout for `SSH login brute force` be configured?

I found the scan became very slow specially in 99% and my CPU load becomes very high. I don’t kown why. And I want to test whether reducing this value will decrease the scanning time and lower CPU load.


You can edit VT-specific settings for each VT from the scan configuration. You cannot edit Greenbone’s default scan configurations, so you have to first clone the scan config you are using (i.e. Full and Fast).

  1. Go to the scan configs page from the top menu bar (Configuration → Scan Configs)
  2. Clone the scan config you are using (Sheep icon at far left of the scan config)
  3. Edit the cloned scan config
  4. Find the specific NVT you want to change settings (This one is in the “Brute Force” family and is called “SSH Brute Force Logins With Default Credentials” as you know
  5. Click the edit button at the far right of that NVT item
  6. Change the timeout value and save it

Thanks for specifying !

1 Like