How can I use gvm-cli with my ospd-openvas?

Hello everyone. Sorry for asking so many questions on my build. I have been tinkering and reading the documentation on getting gvm-tools to work with my environment and I run into this error linking my ospd.sock from my ospd wrapper: Invalid response from manager daemon while requesting the version information.

The command I run is like so:
gvm-cli socket --sockpath $GVM_INSTALL_PREFIX/var/run/ospd.sock --xml "<help/>"

I followed the installation process using this website: The documentation on how to use gvm-cli came from these documents:

My environment uses Ubuntu 20.04, and the libraries I have installed are as follows:
gvm_libs: 20.8.0
openvas_scanner: 20.8.0
ospd: 20.8.1
ospd_openvas: 20.8.0

I have read that gvmd would need to be installed so I can use the unix socket that gvmd provides to allow gvm-cli to work. Is this right, or am I missing something when I setup ospd-openvas on my system?

Ok, I’m dumb. I wasn’t inputting the --protocol OSP for my ospd-openvas socket. What it should look like is like so:
gvm-cli --protocol OSP socket --sockpath $GVM_INSTALL_PREFIX/var/run/ospd.sock --xml "<help/>"

Found this in Greebone’s forums. Thanks all!

1 Like