Host Header Frustration

Host header error.The request contained an unknown or invalid Host header. If you are trying to access GSA via its hostname or a proxy, make sure GSA is set up to allow it.

I’ve followed all the possible google results for this error. Running Kali Rolling.

I’ve moved the topic to Greenbone Source Edition because you are clearly not using our Greenbone Community Edition Virtual Machine.

For answering your question I only can quote myself

bricks. I’ve have followed these instructions. Nothing solves this issue. Why is there not a simple explanation of this? I do realize you have explained this topic. But if you google “gsa invalid host header” you will see that this is still a major issue.

Tried this numerous times. Same error

Please try to provide some more details as it is currently hard to guess what you already did and how your setup looks like. This additional info could be:

  1. Is there a proxy or similar in between the GSA?
  2. What files have you tried to edit to allow the required host header?
  3. Any additional steps you have tried to solve this issue.