Host Discovery - No redis DB available

While my install is not strictly from sources, i am using ppa:mrazavi/gvm as a base. I have tasks and hosts, scans and nvt updates running very smoothly. Today, i tried to setup a Host Discovery Task and get a ton of “No redis DB available” in openvas.log. If i run a scan on any other target everything works well, as does openvas -u, which purports to write updates to redis. My redis server what i know should be the correct items, its only this one task.

Does it use a specific DB #, i need to clear, as i notice multiple indexed databases are used in redis?

I do understand that this may not a a setup you directly support. But since its only impacting a Host Discovery scan and all other scans work fine. Thought this would be a good place to look for help.
When posting you should provide information about your environment using the following template:

GVM versions

gsad --version
Greenbone Security Assistant 9.0
gvm: (‘gvmd --version’)
Greenbone Vulnerability Manager 9.0.0
Manager DB revision 221
Copyright © 2010-2017 Greenbone Networks GmbH
License GPLv2+: GNU GPL version 2 or later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
openvas-scanner: (‘openvassd --version’)
So my system has ospd-openvas, the version is as follows
ospd-openvas --version
OSP Server for openvas: 1.0.0
OSP: 1.2
OSPd: 2.0.0
I’m have nothing outside of the standard install.


Operating system: Ubunutu
Kernel: (‘uname -a’)
Linux stagingopenvas 4.15.0-1060-aws #62-Ubuntu SMP Tue Feb 11 21:23:22 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
Installation method / source:
Source with the ppa helper.

Hi @jeffd,

I suggest to read the available documentation about the Redis data model for OpenVAS.
It will probably help to find the issue.
You can check the “databases” and “maxclients” settings in the redis configuration file. You can find more info here.


Hey @jjnicola

Thanks for the link. I had read that a while ago, about 4 months when first starting out, and have been on and off other projects, and mostly scanning groups of hosts (databases etc) so clearly i didn’t have enough available databases for a /24 scan. I can successfully run now with no CRITICAL messages, i have increased databases to 512 and reduced concurrency in the task to 5.

Now to find out why the report is still empty. Appreciate the input and teaching/reminding a man to fish

I think we can consider this closed. I still need to figure out why i have an empty report when logs are not throwing any error of any kind. but that is a different topic. Enjoy PI